Closed Bug 170973 Opened 17 years ago Closed 17 years ago

Links are not clickable

Categories

(Core :: DOM: CSS Object Model, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 102695

People

(Reporter: talibmorgan, Assigned: jst)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

It may be the way that this page is built - or maybe not, but using Mozilla 1.1,
none of the images are clickable.  Strangely enough, the page works just fine
when I use Phoenix 0.1.

It doesn't look like the page is using too much that's non-standard.  I'm
guessing that maybe there's a bug in the HTML that's causing Mozilla to ignore
the HREFs.

Talib
I also see this behaviour using Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1)
Gecko/20020826. It seems it may be due to invalid HTML (a <div> layer misspelled
as <duv>). I'll attach a testcase.
added testcase keyword
Keywords: testcase
wfm using build 2002092604 on Win2k (trunk).
Confirming problem with Windows XP on 2002091014.

In IE all links are clickable.
In Moz, anything that loaded off-screen (the stuff you need to scroll down to
see), IS clickable. However, what loaded on the screen is not clickable.

At 1024x768 the bottom of what is visible before scrolling is the underline of
one of the links that says "Fri Jul 19 2002", so even though the words aren't
clickable, once you scroll down or pagedown, the underline of that very same
link *is* clickable.



***** Please modify your testcase with a longer page which has links that will
load off-screen at most resolutions, and i'm sure you will find the off-screen
links become clickable.

> Please modify your testcase with a longer page
I'm not sure how that would help? The reason the links further down the page
become clickable is because when you scroll/page down, those links are no longer
under the absolutely-positioned layer (which is causing this due to invalid HTML).
Sorry, I mis-read the text in your testcase and was simply trying to provide
further information to the example.
->DOM Style (please punt as required)

Assignee: asa → jst
Component: Browser-General → DOM Style
QA Contact: asa → ian
The problem here is that IE allows clicking through divs and we do not.  That's all.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.