Cannot compose or reply to any mails

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Dave Fennell, Assigned: varada)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

This is really serious...

When I try to create a mail the compose window comes up with "..." in the from
combo... Nothing I do can get my account to appear in there.  The same occurs
when I create a new mail with "Compose" from the menu or if I try and reply to
an existing mail in my Inbox.  

I have tried adding a new account and that does not appear either.

Reproducible: Always

Steps to Reproduce:
1.Click Compose.

Actual Results:  
I just get "..." in the From combo and nothing works! You can type a subject and
to address, but the subject is never accepted (it says "no subject" all the
time)... None of the pretty graphic buttons at the top do anything nore can I
attach files or write the message body.

Expected Results:  
Let me send the mail!

I have tried :

1. Installing 1.2a over 1.1b.
2. Uninstalling 1.2a then re-installing.
3. Adding new mail accounts, changing settings etc.

Finally when I uninstall 1.2a and re-installing 1.1b it all works properly
again, In conclusion 1.2a is COMPLETELY UNUSEABLE FOR ME!

A colleague in my office is using 1.2a with no problems on the same mail server,
we are both on W2K using similar machines.  The only noteable difference I can
think of is that I have installed W2k Service Pack 3 and he has not...

Comment 1

16 years ago
Fixing summary (Reporter: please don't use all caps).
Summary: CANNOT COMPOSE OR REPLY TO ANY MAILS!! → Cannot compose or reply to any mails
over to varada.
Assignee: ducarroz → varada
Works fine for me using a early debug trunk build from today on Win2k. Does
anybody else see that problem?
(Assignee)

Comment 4

16 years ago
I am not seeing this on today's build either. Can you create a new attachment
with your prefs.js after replacing any personal data with Xs or foobars.
(Reporter)

Comment 5

16 years ago
Created attachment 100843 [details]
prefs.js (personal data blanked)

AS requested...
(Reporter)

Comment 6

16 years ago
I have found several "*prefs.js" files on my computer, here is a list in case it
is  relevant :

C:\Documents and Settings\dave\Application
Data\Mozilla\Profiles\default\3zpxj0d0.slt - prefs.js (attached) and liprefs.js

C:\Program Files\Netscape\Users\default pres.js and liprefs.js

C:\Program Files\mozilla.org\Mozilla_old\defaults\pref security-prefs.js

C:\Program Files\mozilla.org\Mozilla\defaults\pref security-prefs.js

I have netscape 4.76 installed which is the Netscape stuff I assume.
I also use the Microsoft "automatic upgrade" thing which downloads patches,
according to my "Add/Remove programs it has installed the following "Hotfixes":

Windows 2000 Hotfix (Pre-SP4) [See Q320206 for more information]
Windows 2000 Hotfix (Pre-SP4) [See Q322842 for more information]
Windows 2000 Hotfix (Pre-SP4) [See q323172 for more information]
Windows 2000 Hotfix (Pre-SP4) [See Q324096 for more information]
Windows 2000 Hotfix (Pre-SP4) [See Q324380 for more information]
Windows 2000 Hotfix (Pre-SP4) [See Q326830 for more information]
Windows 2000 Hotfix (Pre-SP4) [See Q326886 for more information]

The only "web" related thing I have installed (apart from standard stuff) in the
sun Java2 runtime environment...

Comment 7

16 years ago
Confirmed on the win32 20020927xx build (had to rever to yesterdays)

It seems to be choking before the sig is placed in the message body.
(Assignee)

Comment 8

16 years ago
Have you tried creating a new profile and trying to access mail- you mentioned
new accounts but I dont know that if you have tried a fresh profile.

Comment 9

16 years ago
noew WFM with the win32 2002092708 trunk build.

Comment 10

16 years ago
New behavior:  When focus is moved to message body, the cursor is *after* the
sig, not at the start of text.
(Reporter)

Comment 11

16 years ago
No I did not try a new profile...I have uninstalled that version and didn't plan
to upgrade again until there was a useable one!

Incidentally I do not have a signature and it always annoys me that the cursor
goes to the bottom of the mail and not the start (is this to do with not having
a signature?)... If I type messages there I tend to get strange replies from
people who assume I've accidentally forgotten to type anything! (they have not
looked all the way down).

How many confirmations does it take until a bug is marked confirmed ?
(Reporter)

Comment 12

16 years ago
Sorry, my last comment was not very clear... I meant when replying to/forwarding
emails the cursor always starts at the end of the copied message, instead of the
start.
(Assignee)

Comment 13

16 years ago
Dave so far you are the only one who is experiencing this problem so we cannot
mark it as a confirmed bug and even if we did we would have to mark it as WFM
because neither the daily smoketest blockers nor anyone else is able to
reproduce this.
 Can you try a new profile and let me know if that works?
(Reporter)

Comment 14

16 years ago
I though comment #7 had confirmed this bug?

Comment 15

16 years ago
yes, and my comment #9 confirmed WFM with a later build.  It was only busted fro
a short time.  Now it works fine (for me).
(Reporter)

Comment 16

16 years ago
Following your instructions I have been playing with the "profile manager".  In
Moz 1.1b I have one profile called "default" (apparently).  When I install 1.2a
and start the profile manager it lists no profiles at all (but does allow me to
run browser and mail).   I tried creating a profile called "dave" which appeared
in the list, however clicking "Start Mozilla" button at the button refused to
actually start.  So I closed the profile manager (using the X) and then reopened
it to be presented with no profiles again...Interestingly neither the browser or
mail would now run, they just bring up the profile manager.  I tried the same
procedure again this time with a profile called "default user"... Again it
dissappeared when I closed the profile manager.  Because I could not run the
browser I uninstalled 1.2a and re-installed 1.1b.  When I go into the profile
manager in 1.1b all three profiles "default", "dave" and "default user" were listed.

Apparently you were right to suspect the profiles...
(Assignee)

Comment 17

16 years ago
Are you running on turbo? If so disable turbo and then exit the application.
Launch the profilemanager from the startmenu/programs. If you are experiencing
problems with the profiles - there should be a bug logged against it. 
Closing this bug as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

16 years ago
What is turbo!?  I was launching the profile manager from the start menu, with
all browser/mail windows closed.
(Assignee)

Comment 19

16 years ago
turbo=quicklaunch ;if you see the little mozilla icon on your system tray.
(Reporter)

Comment 20

16 years ago
No I don't use that.

I have downloaded a nightly build (yesterday) Mozilla/5.0 (Windows; U; Windows 
NT 5.0; en-US; rv:1.2b) Gecko/20020930 and unfortunately it is loads worse!  
The thing crashes everytime I click "tools" and the mail window always wants me 
to create a new account! (so I can't even see if it has the same bug)... and 
whats worse is that uninstalling it and installing a previous version doesn't 
work anymore!  Bummer.
(Reporter)

Comment 21

16 years ago
I had this bug but I have fixed it by uninstalling and completely deleting the
mozilla.org directory.  When I re-installed 1.2 the bug was gone - I guess there
is some incompatibility between the versions? 
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.