form submit within a flash plugin causes Internet Explorer to start

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: paxunix, Assigned: peterl-bugs)

Tracking

({qawanted})

Trunk
Future
x86
Windows 98
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [QA: request for test help], URL)

(Reporter)

Description

16 years ago
Trunk build 2002092604 (though reproduceable with trunk nightlies from the past
several weeks, at least--beyond that I don't know since I hadn't yet been using
the above URL).

Reproduce:

1. Go to the above URL and click on the flash plugin in the lower left corner of
the page (it has "Orbit Login" displayed on it).

2. Click the "Join Orbit Now" button within the plugin.

3. Note that nothing appears to happen.  This may be a separate bug.  I've
waited up to 10 minutes after this point to make sure there wasn't a delay
before some action occurred.  The javascript console has no new warnings or errors.

4.  Switch tabs or move the focus to another window.  (Other actions may work,
but tab switching is 100% reliable for me).

5.  Go back to the tab/window from step 1 and click the same "Join Orbit Now"
button from step 2 again.

6.  Notice that Internet Explorer opens up with a javascript URL that looks like
it should be processed by Mozilla.  Still nothing new on javascript console.

I realize this may be a flash vendor issue, but I do NOT see the same behavior
in a NS7 install so I suspected Mozilla.

I sincerely hope I'm not the only one that sees this.  I have done a complete
reinstall of mozilla to try to ensure it wasn't a prior installation artifact,
but the problem persists.

Comment 1

16 years ago
Not JavaScript Engine. Reassigning to Plug-ins for further triage -
Assignee: rogerl → beppe
Component: JavaScript Engine → Plug-ins
QA Contact: pschwartau → shrir

Comment 2

16 years ago
I could not duplicate this issue with a trunk build from 20020930 on winXP. What
browser do you have set as your default browser?

Comment 3

16 years ago
wfm
(Reporter)

Comment 4

16 years ago
This happens on a Win98 machine with IE, NS7 and Mozilla installed.  The profile
I use is only used with Mozilla, not NS7.  Recently upgraded IE to version 6 and
installed the script debugger for IE (although the problem may have been
occurring before then).  A clean Mozilla profile did not solve the problem. 
I'll try on a different machine (although it's Win2K) and see if I can reproduce
this.

Is there any way that the flash plugin could think that IE should be used even
if the plugin was currently operating in Mozilla?

Comment 5

16 years ago
Oh yeah, that could happen quite easily. You can check to see if the Mozilla
browser or NSCP browser is the default by going to Edit|Preferences|Navigator
and see if the setting has been made. If it is not, try setting that option and
see if this still happens. I suspect that you did not have this set.
(Reporter)

Comment 6

16 years ago
Turns out I did not have Mozilla set as my default browser.  Since it's my
wife's machine and she prefers NS7, Mozilla never becomes the default.  However,
just in case, I made Mozilla the default via the button in Navigator
Preferences.  Restarted just to be sure everything was copacetic.  Still got the
same behavior at the above URL.

Was unable to reproduce this with a perfectly clean Mozilla install on a Win2K
machine.  Perhaps I'll throw NS7 into the mix on that box to see if it coughs
something up.

Comment 7

16 years ago
oh, I bet I know what it is -- I suspect the flash plug-in in looking for the
first instance in the registry that equals Netscape and on your wifes system
that happens to be 4.x. If you install 4.x on your system and you get the same
behavior, then I would suspect that that is the issue. 

Shrir: can you help verify this on one of the test machines?
Whiteboard: [QA: request for test help]

Comment 8

16 years ago
reassign
Assignee: beppe → peterl
Keywords: qawanted

Comment 9

16 years ago
WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P5
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.