Closed Bug 1710037 Opened 7 months ago Closed 7 months ago

[MacOS]Button(s) not reachable on Proton infobars via keyboard navigation

Categories

(Firefox :: Keyboard Navigation, defect)

Unspecified
All
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox89 --- affected
firefox90 --- affected

People

(Reporter: peter.magyari, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-infobars])

Affected versions
Nightly 90.0a1
Beta 89.0b9

Affected platforms
MacOS 10.15.7
MacOS 11.2.3

Steps to reproduce

  1. Launch Firefox
  2. Navigate to https://permission.site/
  3. Click on "Protocol Handler" inside the page
  4. Navigate to the "Protocol Handler" infobar using "TAB"

Expected result
Using "TAB" you can navigate to the "Add application" button

Actual result
The "Add application" button cannot be selected via the keyboard
The "X" close button and the "Learn more" hyperlink however, are selectable.

Notes
I wasn't able to reproduce this issue on an older MacBook Pro (2015)
This behaviour is reproducible on other infobars as well

Summary: Button(s) not reachable on Proton infobars via keyboard navigation → [MacOS]Button(s) not reachable on Proton infobars via keyboard navigation

Is this with the full keyboard setting enabled? (System Preferences -> Shortcuts -> Check the 'Use keyboard navigation...' checkbox at the botttom)

With that enabled, all three items should be in the tab order (Add application, Learn more and the close button). With that disabled, none of the three should be in the tab order.

You are right, I've checked and that was already "checked" on my older Macbook so that is why I couldn't reproduce it there.

Thanks Neil!

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.