Closed Bug 1710072 Opened 1 year ago Closed 6 months ago

Upload firefox.exe to the symbol server

Categories

(Firefox Build System :: General, defect, P3)

defect

Tracking

(firefox-esr91 wontfix, firefox94 wontfix, firefox95 wontfix, firefox96 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- wontfix
firefox94 --- wontfix
firefox95 --- wontfix
firefox96 --- fixed

People

(Reporter: jrmuizel, Assigned: gsvelto)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

See bug 1548018 for some context.

This was apparently broken by bug 1255485

Regressed by: 1255485
Has Regression Range: --- → yes

The Bugbug bot thinks this bug is a defect, but please change it back in case of error.

Type: enhancement → defect

I believe that this is a Release Engineering request.

Product: Firefox Build System → Release Engineering
QA Contact: mtabara

Err, a build patch regressed this, so it belongs in Firefox Build System. My bad.

Product: Release Engineering → Firefox Build System
QA Contact: mtabara
Assignee: nobody → mhentges
Status: NEW → ASSIGNED

De-prioritizing this a bit, since (AIUI) symbols for xul.dll still load:

The fact that xul.dll loads means that this is not as high priority as I thought because usually having xul.dll is sufficient.

Assignee: mhentges → nobody
Status: ASSIGNED → NEW
Priority: -- → P3

This also adds documentation and renames the function tasked with this job to
clarify that we're not only copying the file holding the debug information but
also the corresponding executable or library.

Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efa411081b2f
Copy executables for all programs in the full crash reporter symbols archive r=Gankra
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
You need to log in before you can comment on or make changes to this bug.