Closed Bug 1710323 Opened 1 year ago Closed 1 year ago

Should clean up temporary attachment files after sending

Categories

(MailNews Core :: Composition, defect)

defect

Tracking

(thunderbird_esr78 wontfix, thunderbird89 fixed)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird89 --- fixed

People

(Reporter: rnons, Assigned: rnons)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1710220 +++

Two types of temporary attachment files remain in the tmp folder after sending

  1. when editing a draft/template that contains attachments, tmp files are created by mimedrft.cpp
  2. when attaching public key to a message, a tmp file (key.asc) is created by nsMsgComposeSecure.cpp

Before bug 1710220, they were removed by MimePart.jsm, but that is the cause of 1710220.

This problem also exists when using nsMsgSend.cpp, but we will only fix the new js backend.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Keywords: regression
No longer regressed by: 1211292
See Also: → 1710572
Duplicate of this bug: 1710572
Target Milestone: --- → 90 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/03ce93477849
Remove temporary attachment files when closing compose window. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Just a general comment: There is nsIExternalHelperAppService.deleteTemporaryFileOnExit()
https://searchfox.org/comm-central/search?q=deleteTemporaryFileOnExit&path=&case=false&regexp=false

Comment on attachment 9221263 [details]
Bug 1710323 - Remove temporary attachment files when closing compose window. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1211292
User impact if declined: Temporary attachment files are not cleaned up after sending
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9221263 - Flags: approval-comm-beta?

Comment on attachment 9221263 [details]
Bug 1710323 - Remove temporary attachment files when closing compose window. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9221263 - Flags: approval-comm-beta? → approval-comm-beta+
Regressions: 1727830
Regressions: 1735601
Regressions: 1746860
You need to log in before you can comment on or make changes to this bug.