Closed Bug 1710380 Opened 1 month ago Closed 1 month ago

Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_navigation.py TestBackForwardNavigation.test_certificate_error - marionette_driver.errors.TimeoutException: TimedPromise timed out after 300000 ms (with fission.bfcacheInParent)

Categories

(Testing :: Marionette, defect, P3)

Default
defect

Tracking

(Fission Milestone:M7a, firefox89 disabled, firefox90 disabled)

RESOLVED DUPLICATE of bug 1711753
Fission Milestone M7a
Tracking Status
firefox89 --- disabled
firefox90 --- disabled

People

(Reporter: whimboo, Assigned: smaug)

References

(Blocks 1 open bug)

Details

(Keywords: test-disabled)

Even after my patch on bug 1704697 this test will still fail with BFCache in parent enabled (fission.bfcacheInParent=true).

The problem is that after the remoteness change no page load even is emitted:

1620637586014	Marionette	DEBUG	2 -> [0,28,"WebDriver:Back",{}]
1620637586016	Marionette	TRACE	Remoteness change detected. Set new top-level browsing context to 47
1620637886016	Marionette	DEBUG	2 <- [1,28,{"error":"timeout","message":"TimedPromise timed out after 300000 ms","stacktrace":"WebDriverError@chrome://marionette/ ... .js:181:5\nTimeoutError@chrome://marionette/content/error.js:450:5\nbail@chrome://marionette/content/sync.js:229:

Olli mentioned that these kind of pages might not end-up in BFCache at all. So it looks like there is some work to do on the platform level.

Flags: needinfo?(bugs)

We don't want those pages to enter bfcache. But the previous page might enter bfcache. There should be DOMContentLoaded

Flags: needinfo?(bugs)
Severity: -- → S3
Priority: -- → P3

(In reply to Olli Pettay [:smaug] from comment #1)

We don't want those pages to enter bfcache. But the previous page might enter bfcache. There should be DOMContentLoaded

Is there an existing DOM bug for that yet so we can mark it being blocked?

Flags: needinfo?(bugs)

I'm not aware of any DOM bug here :)

Flags: needinfo?(bugs)
Fission Milestone: --- → M7a

Fission M7a because this blocks Fission bfcache

Olli will take a look after WebDriver bug 1704697 is fixed.

Assignee: nobody → bugs
Depends on: 1711753
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1711753
You need to log in before you can comment on or make changes to this bug.