Closed Bug 1710439 Opened 5 months ago Closed 5 months ago

SeaMonkey automatic update does not remove extensions in distribution/extensions

Categories

(SeaMonkey :: Installer, task, P3)

Other
All

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.87
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: frg, Assigned: frg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.8)

Attachments

(1 file)

When testing the automatic update to 2.53.7.1 I found that the updater added the distributed extensions correctly to extensions but didn't remove the old ones. I think removed-files.in needs to be updated.

Summary: SeaMonkey automatic update does not removed extension in distribution/extensions → SeaMonkey automatic update does not remove extensions in distribution/extensions

Not sure if my theory is correct. First one who thinks it is can r/a+ :)

[Approval Request Comment]
Regression caused by (bug #): 1659298
User impact if declined: obsolete extensions retained
Testing completed (on m-c, etc.): not able to test
Risk to taking this patch (and alternatives if risky): no risk no fun
String changes made by this patch: --

Attachment #9221138 - Flags: review?(iann_bugzilla)
Attachment #9221138 - Flags: review?(ewong)
Attachment #9221138 - Flags: approval-comm-release?
Attachment #9221138 - Flags: approval-comm-esr60?

Comment on attachment 9221138 [details] [diff] [review]
1710439-distri-2538.patch

[Triage Comment]
LGTM r/a=me

Attachment #9221138 - Flags: review?(iann_bugzilla)
Attachment #9221138 - Flags: review+
Attachment #9221138 - Flags: approval-comm-release?
Attachment #9221138 - Flags: approval-comm-release+
Attachment #9221138 - Flags: approval-comm-esr60?
Attachment #9221138 - Flags: approval-comm-esr60+
Attachment #9221138 - Flags: review?(ewong) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.87
You need to log in before you can comment on or make changes to this bug.