Closed Bug 1710751 Opened 1 year ago Closed 1 year ago

Voiceover Firefox In page links like help page and skip navigation do nothing (only work around is navigation by header)

Categories

(Core :: Disability Access APIs, defect)

Firefox 89
Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox90 --- verified

People

(Reporter: testertesting989, Assigned: morgan)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36

Steps to reproduce:

MacOS 10.15.7 / 11.3
Firefox 89.0b8
https://capt-tds-uat.cambiumast.com/student

  1. Start VoiceOver
  2. Launch browser to https://capt-tds-uat.cambiumast.com/student
  3. Click Sign In and on the next page select a grade and then press a test button.
    4.On the settings page select "braille" presentation, and then press select button.
  4. If a sound check comes up, press to play and then press "I heard the sound" and finally the continue button.
  5. On the Instructions and Help page, click the button with a ? lalabeled "View help guide". Click any of the links at the top of the instructions using control-option--space, or the return key.

Actual results:

Focus remains on the link

Expected results:

Focus moves to the heading associated with the link

OS: Unspecified → macOS

The Bugbug bot thinks this bug should belong to the 'Core::Disability Access APIs' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Disability Access APIs
Product: Firefox → Core

Looking very briefly, it seems we don't handle Gecko's EVENT_SCROLLING_START on Mac, which we would need to handle to support anchor jumps.

Hardware: Unspecified → Desktop
Severity: -- → S3
Assignee: nobody → mreschenberg
Status: UNCONFIRMED → NEW
Ever confirmed: true
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8b8dd8a7814
Create LINKS_TO relation to track anchors and their corresponding elements r=eeejay
Flags: needinfo?(mreschenberg)
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13a48807371b
Create LINKS_TO relation to track anchors and their corresponding elements r=eeejay
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Flags: qe-verify+

Hello! Reproduced the issue with Firefox 90.0a1 (20210511213906) on macOS 11.3.
The focus is working as intended with 90.0b4 (20210606185718) after following STR from comment 0 and using control-option-space to navigate. I noticed that when using the return key the issue is still reproducible. Morgan, can you please have a look? Thank you!

Flags: needinfo?(mreschenberg)

hi! I think that's a related but different bug -- I fixed this without responding to the SCROLLING_START event Jamie mentioned above, which VO is happy with, but core probably isn't. Could you file a separate bug for that? I can reproduce locally. It also doesn't seem to work with "space" alone.

Flags: needinfo?(mreschenberg) → needinfo?(alexandru.trif)
See Also: → 1715445

Thank you, Morgan! I filled bug 1715445 and I'm going to close this one as verified based on the above.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(alexandru.trif)
You need to log in before you can comment on or make changes to this bug.