shockwave crashes [@ @0xffff06e7]

RESOLVED WONTFIX

Status

Plugins Graveyard
Shockwave (Adobe)
--
critical
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: timeless, Assigned: rubydoo123)

Tracking

({crash})

Details

(crash signature)

(Reporter)

Description

16 years ago
I don't think I installed flash, i know i didn't install flash in mozilla.

If mozilla is supposed to have protection against plugins crashing, it's failing
here.

note that i crash for any flash page, not just random ones (see talkbacks from
my email address)

possible resolutions:
1. don't copy plugins if they aren't working
2. don't use a plugin if it won't work
3. don't let this specific crash in flash can mozilla
--
Shockwave Flash

    File name: NPSWF32.dll

    Shockwave Flash 5.0 r41

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Flash swf Yes
application/futuresplash FutureSplash Player spl Yes
--
Stack Signature 0xffff06e7 c3db5c17
Email Address timeless@bemail.org
Product ID MozillaTrunk
Build ID 2002092511
Trigger Time 2002-09-26 14:06:57
Platform Win32
Operating System Windows NT 5.0 build 2195
Module
URL visited http://random.yahoo.com/bin/ryl
User Comments random sites. i was trying to load lots and lots of web pages, i'm
using yahoo's random site as my home page and dragging it to the new tab icon
Trigger Reason Access violation
Source File Name
Trigger Line No.
Stack Trace
0xffff06e7
NPSWF32.dll + 0xbb7a (0x1000bb7a)
NPSWF32.dll + 0xae46 (0x1000ae46)
USER32.DLL + 0x591b (0x77e1591b)
USER32.DLL + 0x65a4 (0x77e165a4)
ntdll.dll + 0x1fb83 (0x77f9fb83)
nsView::SetDimensions [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 527]
nsViewManager::ResizeView
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2477]
nsLineLayout::ReflowFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineLayout.cpp, line 1268]
nsInlineFrame::ReflowInlineFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsInlineFrame.cpp, line 723]
nsInlineFrame::ReflowFrames
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsInlineFrame.cpp, line 530]
nsInlineFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsInlineFrame.cpp, line 443]
nsLineLayout::ReflowFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineLayout.cpp, line 1048]
nsBlockFrame::ReflowInlineFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3880]
nsBlockFrame::DoReflowInlineFrames
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3708]
nsBlockFrame::DoReflowInlineFramesAuto
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3612]
nsBlockFrame::ReflowInlineFrames
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3557]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2593]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2276]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
nsBlockReflowContext::ReflowBlock
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, line
537]
nsBlockFrame::ReflowBlockFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3316]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2498]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2276]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
nsBlockReflowContext::ReflowBlock
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, line
537]
nsBlockFrame::ReflowBlockFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3316]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2498]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2276]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableCellFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableCellFrame.cpp, line 945]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableRowFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1312]
nsTableRowFrame::IncrementalReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1197]
nsTableRowFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1465]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableRowGroupFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1630]
nsTableRowGroupFrame::IncrementalReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1298]
nsTableRowGroupFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1207]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableFrame.cpp, line 3034]
nsTableFrame::IncrementalReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableFrame.cpp, line 2759]
nsTableFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableFrame.cpp, line 2018]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableOuterFrame::OuterReflowChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1027]
nsTableOuterFrame::IR_InnerTableReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1341]
nsTableOuterFrame::IR_TargetIsInnerTableFrame
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1127]
nsTableOuterFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1117]
nsTableOuterFrame::IncrementalReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1079]
nsTableOuterFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableOuterFrame.cpp, line 1581]
nsBlockReflowContext::ReflowBlock
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, line
537]
nsBlockFrame::ReflowBlockFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3316]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2498]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2276]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableCellFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableCellFrame.cpp, line 945]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableRowFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1312]
nsTableRowFrame::IncrementalReflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1197]
nsTableRowFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowFrame.cpp, line 1465]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 809]
nsTableRowGroupFrame::IR_TargetIsChild
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1630]

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
this  issue about 5.x flash was filed a few days ago. gotta find the dup. This 
does not happen with 6.x versions of flash 
(Assignee)

Comment 2

16 years ago
timeless: you need to upgrade to a more current version of flash, please upgrade
to a supported version and try this again, you should notice that it works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

16 years ago
that's not fare. flash5 is a generally agreeable plugin, it didn't cause serious
damage to n4 and for a while i never saw problems in it in mozilla. Whlie it's
not the current product from macromedia, that's not the issue.

This bug is about the fact that mozilla's plugin crash protection failed, not
that flash sucks. If you can't do anything to fix mozilla to handle the case
when flash then verify wontfix.

also 2002092904 didn't crash when i visited some flash site.
Is the problem that the flash5 plugin crashes whenever it encounters flash6 content?

Comment 4

16 years ago
I think the Flash 5 crash was fixed by another checkin which is why it appears
to have dissapeared in daily builds. 
(Reporter)

Comment 5

9 years ago
i did a bit of bonsai spelunking (because i had to touch this bug and why not), afaict, peter could only have meant:
bug 132759, bug 167601, bug 169753, bug 164043, bug 165368, bug 166713, or bug 165287

And I can't figure out which one :(. My guess is bug 169753
Summary: shockwave crashes [ @0xffff06e7] → shockwave crashes [@ @0xffff06e7]
(Reporter)

Updated

8 years ago
Component: Plug-ins → Shockwave (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-shockwave
Version: Trunk → unspecified
Crash Signature: [@ @0xffff06e7]
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.