CVS checkin access request for Rick.Ju@sun.com

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: Rick.Ju, Assigned: marcia)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020618
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020618

I'd like to apply for my cvs checkin access. My interests are mainly in layout
and calendar. 


Contributions:
 bug 92980:   Fixed. r=jkeiser sr=kin
        guess out IE6's algorithm and provide patches.
 bug 166750:  Checked in. r=jkeiser sr=kin
        p1 critical crasher. provide patch
 bug 50998: Fixed. r=biesi  sr=rbs
        p2 normal.  provide patches for qt/mac/mac/photon/beos platforms
 bug 170225: Fixed. r=jkeiser sr=bryner
        p2 regression crasher. provide patches.
           


  

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Too early... Need to learn more.

Comment 2

16 years ago
I don't know how stringent the requirements are for checkin, but I know Rick is
a good programmer and works well with others.  I will vouch.
(Reporter)

Comment 3

16 years ago
rbs,
   surely i'll work hard to fix more bugs and learn more ASAP :) i am working on
some other bugs these days and hope to get them fixed soon.

john,
   thanks  for ur vouching

knous,
   i have faxed the form. did u get it?
(Assignee)

Comment 4

16 years ago
Form received. 
Status: NEW → ASSIGNED
sr=bzbarsky.  Rick has been doing good work in layout.

Comment 6

16 years ago
I agree with Bzbarsky, Rick has been doing good job on fixing layout problems, I
vouch for Rick.

BTW, Rick, I suggest you update your working list here in bugzilla. 

 
(Reporter)

Comment 7

16 years ago
Thanks, BZ and Jay.

Update

 bug 92980: The input text box shows only 6 characters
	guess out IE6's algorithm and provide patches.
        Fixed. r=jkeiser sr=kin
 bug 166750: Crash on select box with style="position: fixed" inside block box
with style="overflow: auto" [@ nsBlockBandData::Init]
        p1 critical crasher
        Fixed. r=jkeiser sr=kin
 bug 50998:XP impl of GetAveCharWidth and remove ifdef _win32 in GfxText 
        p2 provide patches for qt/mac/mac/photon/beos platforms
	Fixed. r=biesi  sr=rbs
 bug 170225: Fixed. r=jkeiser sr=bryner
        p2 regression crasher. provide patches.   
 bug 128873: tables without cells but with style="table-layout: fixed; width:
100px;" have zero width
        Fixed. r=karnaze sr=bzbarsky
 bug 175670 175670: changing type of input field with javascript crashes mozilla
[@ nsTextControlFrame::PreDestroy]
        Fixed. r=karnaze sr=bzbarsky
 bug 181644 181644: Absolute positioned inline in Abs Pos block is slided up
        Fixed. r=bzbarsky  sr=roc+moz: 

 bug 153995: Button on table inside form bleeds over form border
	r=karnaze sr=bz


other contributions include but not limited to(only some I can recall):
 bug 166596: working in progress
	 Crash saving page with border padding issues [@ 
nsStyleContext::GetBorderPaddingFor]
 bug 112357: wontfix. 
         images don't wrap in fixed-width tables
 bug 176305, bug182597, bug186635...      

sr=bryner.  looks like good work.

Comment 9

16 years ago
sr=kin@netscape.com - Rick seems to have gotten a bit more familiar with how
layout works over the last few months so I'd be comfortable giving him checkin
privileges.

rbs, do you still have any objections?

Comment 10

16 years ago
No further objections from my end.
(Reporter)

Comment 11

16 years ago
Thanks you all! 
(Assignee)

Comment 12

16 years ago
rbs: are you giving an sr=? If so I can activate Rick's account. thanks. 

Comment 13

16 years ago
sr=rbs
(Assignee)

Comment 14

16 years ago
account activated. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Rick, during some maintenance of the CVS server, it was noticed that your account was not set up correctly. For some reason, your account was "rick.ju@sun.com" instead of the normal "rick.ju%sun.com". This has been corrected, so from now on, you'll need to use "rick.ju%sun.com@cvs.mozilla.org:/cvsroot" for your CVSROOT. Sorry for the inconvenience.
You need to log in before you can comment on or make changes to this bug.