Closed Bug 1711053 Opened 1 year ago Closed 1 year ago

Download items should be clickable before they finish

Categories

(Firefox :: Downloads Panel, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: mtigley, Assigned: ava8katushka)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Items in the downloads panel should be clickable so that users have the option to "queue" opening a download that's in progress once it's finished. This would allow users to avoid having to wait around for the download to finish, re-open the panel, and then click the finished download to open it.

We could consider a workflow similar to Chrome: while a download is in-progress and the user clicks it: show some text under the download saying "Opening in N seconds". If the download is clicked again, it cancels this action.

Assignee: nobody → ava8katushka
Status: NEW → ASSIGNED
Blocks: 1718782
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c204c9f05b2e
Open file after download if user clicked on downloading file. r=mtigley,flod,Gijs

Backed out changeset c204c9f05b2e (Bug 1711053) for causing failures in browser_download_opens_on_click.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/28836bdc8dbc0a1abf9cc0fd9158aef404ef4fda
Push with failures, failure log.

Flags: needinfo?(ava8katushka)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a81a827f54fb
Open file after download if user clicked on downloading file. r=mtigley,flod,Gijs
Flags: needinfo?(ava8katushka)
Flags: needinfo?(ava8katushka)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/81d56321261b
Open file after download if user clicked on downloading file. r=mtigley,flod,Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Duplicate of this bug: 752440
Flags: needinfo?(ava8katushka)
Blocks: 1719949
Blocks: 1732893
You need to log in before you can comment on or make changes to this bug.