[EVENTTARG]email link on this site is not clickable

VERIFIED DUPLICATE of bug 102695

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 102695
16 years ago
16 years ago

People

(Reporter: Thorsten Mika, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020623 Debian/1.2.5-0.woody.1
Build Identifier: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020623 Debian/1.2.5-0.woody.1

the mail link on the right side of the page is not clickable for me.
does not work with mozilla 1.2/1.0 either. seems to be stylesheet-related.
stylesheet is available under

http://www.platero-und-ich.de/standard.css

and is w3c compliant (says jigsaw)

Reproducible: Always

Steps to Reproduce:
no steps necessary, just visit and try.


Expected Results:  
the mail link should be clickable. i thought that maybe i would have to remove
the subject line, but it does not help.

Comment 1

16 years ago
Confirmed on Linux with cvs 20020926.

That mail link in unclickable. Cannot see anything obviously wrong with the
source html.

Comment 2

16 years ago
I can confirm this with 2002092608 on Win2k.
The reason seems to be the HTML table which contains the left menu. It is one
level "above" the main text on the page and is as wide as the page
(width="100%"). As you can see after clicking "Edit page".
It somehow occludes the main page text with that email link. Mouseclicks don't
reach that link. I can't say if the problem is the page's fault... but somebody
else soon will, I think.
->Event Handling.  (Is this a duplicate?)
Assignee: dbaron → joki
Component: Style System → Event Handling
QA Contact: ian → rakeshmishra
Summary: email link on this site is not clickable → [EVENTTARG]email link on this site is not clickable
The "menu" table is "position:fixed" and "width:100%". The containing block for
any fixed element is the viewport, so the "menu" table stretches all the way
across the viewport, covering the email link. Clicking on the email link
actually clicks on the "menu" table, which does nothing. So what we're doing is
quite correct. This is really INVALID, but I'll mark it a duplicate of 102695 so
we can track things.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
As above the problem is with the inner table holding the left menu items. It is
positioned on top of the main table and has an HTML attribute(not css)
width=100%, covering everything to its right. Not only is the link out of reach,
but all the text in this area is unselectable. This may be seen more clearly by
examining one of the other pages on the site such as:

http://www.platero-und-ich.de/musik.html

By simply removing the width value on the inner table, things begin to behave as
expected. Or one could move the width value to the stylesheets and things seem
to work out fine as well. See here (seven lines added before the close of the
head tag):

http://www3.sympatico.ca/dylanfoley/akontakt.html

Though it does change the spacing of the menu links, I think this shows it is
more likely a page authoring problem and not a bug.

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 6

16 years ago
verifying dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.