Closed Bug 1711215 Opened 7 months ago Closed 7 months ago

"Password Manager key" button doesn’t trigger the password panel if clicked near the edges

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- verified

People

(Reporter: emilghitta, Assigned: mconley)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [proton-address-bar] [priority:2b])

Attachments

(2 files)

Attached image passowrdIcon.gif

Affected versions

  • Firefox 90.0a1 (BuildId:20210512174859)
  • Firefox 89.0b12 (BuildId:20210513185752)

Affected platforms

  • Windows 10 64bit.
  • macOS 10.15
  • Ubuntu 20.04

Steps to reproduce

  1. Launch Firefox.
  2. Access the following link
  3. Input a username & password.
  4. Hit the “Log In” button.
  5. Dismiss the Save Login panel by clicking on the page.
  6. Click near the edges of the the password manager key button.

Expected result

  • The password panel is displayed.

Actual result

  • The password panel is not displayed.

Regression Range

  • I’m not 100% sure about the regressor here. The new button styling was implemented in Bug 1701629 which exposes this behavior better and I couldn't reproduce this issue on pre-proton builds.

Notes

  • As a side note I didn’t encounter this problem on other buttons like: “Tracking shield” or “Lock” buttons.
  • For further information regarding this issue please observe the attached screencast.
  • Tentatively adding the [proton-address-bar] whiteboard. Please feel free to change this if necessary.
Priority: -- → P2
Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2b]
Assignee: nobody → mconley
Attachment #9222699 - Attachment description: WIP: Bug 1711215 - Increase notification icon click area with padding. r?harry! → Bug 1711215 - Increase notification icon click area with padding. r?harry!
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a3f6ca8ff667
Increase notification icon click area with padding. r=harry,desktop-theme-reviewers
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Hi, I reproduced this behaviour on Beta 89 and then verified that it has been fixed on Nightly 90.0a1 (2021-05-30).

Regards, Flor.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.