bug_email.pl is broken

RESOLVED FIXED in Bugzilla 2.18

Status

()

RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: jussi, Assigned: alex)

Tracking

({helpwanted, regression})

2.17
Bugzilla 2.18
x86
Windows 2000
helpwanted, regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The schema change from the new groups system broke bug_email.pl. The relevant
part from the script output is:

select bit from groups where name='ReadInternal': Unknown column 'bit' in 'field
list' at globals.pl line 246.

There is propably more references to the old groups table.
Can we consider this a feature? Please? :)
Keywords: helpwanted, regression
Target Milestone: --- → Bugzilla 2.18

Comment 2

16 years ago
Same problem here. Any news on this bug?
ccing the people that have been working with the new groups schema...
CCing Dan Berlin, who from stuff I've seen around, I know is actually using the
bug_email stuff.  I'd appreciate any input or fixes you'd be willing to provide
on these bugs :-)

Comment 5

16 years ago
I've found that if I change all occurances of "bit" to "id" in each of the SQL
statements in bug_email.pl, it will work. Well, I didn't test it very well, but
at least it accepts my emails and puts them in the database.
(Assignee)

Comment 6

15 years ago
Created attachment 129362 [details] [diff] [review]
Fixes group and mail problem

T.R. Fullhart had a partial fix which I have now completed.  His work-around
simply allowed the bug to be entered into the database but would not handle any
groupset nor fix the processmail issue.  My proposed patch fixes both.

Only one caveat, and that is the bug may be entered into a group which the user
has no access rights to.  I did not bother adding this check since this
interface is via email and email is dead easy to fake up.  If the user does
enter an incorrect group, then the groups they are listed in will be given, so
if anyone needs this additional check, it should be easy enough to add.
(Assignee)

Updated

15 years ago
Attachment #129362 - Flags: review?
Comment on attachment 129362 [details] [diff] [review]
Fixes group and mail problem

patch applies and it compiles.	Generally looks good, but haven't tested, but
this is only contrib anyway. :)
Attachment #129362 - Flags: review? → review+
Checking in contrib/bug_email.pl;
/cvsroot/mozilla/webtools/bugzilla/contrib/bug_email.pl,v  <--  bug_email.pl
new revision: 1.16; previous revision: 1.15
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Flags: approval+
Resolution: --- → FIXED
Assignee: justdave → alex
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.