cannot link to sherlock 2 search finds while running Mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Frank Faconti, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910

This has been a long running problem since I began using Mozilla back in April
or so.  When I launch Sherlock 2 and do a search, if I click on any link that
comes up in the search finds, I get the following message - You cannot run this
copy of netscape while another copy of mozilla or netscape is running. 
"Netscape 7.0" will now quit.
Nothing happens after that.  Mozilla doesn't quit and the link doesn't come up
in Mozilla either.  I don't see where there is a way to establish a default
browser in Sherlock 2, but even so, the error message is confusing, alleging
that Mozilla is Netscape 7.0 and it will quit.  Something is not right here. 
This is one major flaw in Mozilla that keeps me from using it consistently, as I
need to run Netscape 4.8 or 7.0 in order to link to Sherlock search finds.

Reproducible: Always

Steps to Reproduce:
1. Run Mozilla.
2. Run Sherlock 2.
3. Search for something in Sherlock 2 and click one of the found search entries.

Actual Results:  
I got the error message - You cannot run this copy of netscape while another
copy of mozilla or netscape is running.  "Netscape 7.0" will now quit.
Then, basically NOTHING happens!

Expected Results:  
Mozilla should have gone to the site that was identified in the link I clicked
in Sherlock 2.

Comment 1

15 years ago
WorksForMe using Mac/2002091908/9.2.2. Frank, is Mozilla your Default Web Browser on the 
Internet control panel's Web tab?
(Reporter)

Comment 2

15 years ago
   I had Netscape Communicator listed as my default browser and went in and
changed it to Mozilla.  I then started Sherlock 2 and tried to link to one of
the listings from a search and instead got the following message - You cannot
run this copy of "Mozilla 1.2a" while another copy of mozilla or netscape 6 is
running.  "Mozilla 1.2a" will now quit.
   I click "OK" and NOTHING happens!  This is definitely a BUG!  No matter what
the default browser is, Sherlock 2 will not link to any listing while running
Mozilla....OvR

Comment 3

15 years ago
Frank, do you have more than one copy of Mozilla installed?

Please be aware Mozilla cannot run if Netscape 6 or 7 is already running.
(Reporter)

Comment 4

15 years ago
I have only one copy of Mozilla installed and I am not running Netscape 6 or 7
when this occurs.  I will note, however, that since I have set Mozilla as my
default browser in the Internet Control Panel, when I was running Netscape 7
(without Mozilla running) and I launched Sherlock 2 and tried to click to a
search link, I got the same error message as I did with Mozilla (You cannot
run this copy of "Mozilla 1.2a" while another copy of mozilla or netscape 6 is
running.  "Mozilla 1.2a" will now quit)!  As in the initial reported case, the
browser does not quit and the link is not called up in the browser.  This is
rather curious, as I was running Netscape 7 and NOT Mozilla - is it possible
that Sherlock is having trouble distinguishing between these variations of Netscape?

Comment 5

15 years ago
Frank, Mozilla and Netscape 7 use the same profiles directory (even though they
can't share profiles; yes, it's stupid). So, they cannot both run at the same
time, ever.

If you have both Netscape and Mozilla quit, and you have Mozilla set up as your
default web browser, and you select a link in Sherlock, Mozilla should launch
just fine. Does it?
(Reporter)

Comment 6

15 years ago
I think I have it working now and figured the problem.  When I set Mozilla as my
default browser (instead of Netscape) in the Internet Control Panel, Mozilla was
running and Sherlock still wouldn't link to its searches.  I noticed the same
thing with Netscape 7 when I changed it back to Netscape with Netscape running
(Sherlock wouldn't link to searches).  This morning, at Greg's prompting, I
tried once more to change Mozilla to my default browser, but this time with NO
browser running and when I booted Mozilla and ran Sherlock, the search link I
clicked on came up fine!

Comment 7

15 years ago
The only thing I can think of is that you changed the default browser in the Internet control panel, 
but didn't actually *save* the settings (by choosing File/Save Settings or closing the control panel 
and saving changes). The default browser change does not take effect until the settings are 
saved.

Is this possibly the problem you were encountering, Frank?
(Reporter)

Comment 8

15 years ago
It's working, but quite frankly I am perplexed as to what is going on here.  I
thought it was because the changes do not take effect until you restart the
browser, but that's not true, as I changed the default browser to Netscape while
running Mozilla and tried Sherlock 2 and the search link gave me the error
message!?!  Then, I changed it back to Mozilla, with Mozilla still running, and
when I clicked on the same link in Sherlock 2, it went to the link!?!  I know I
have been saving each and every change, as if you click the upper left corner of
the window in the control panel to quit, you are prompted to save changes, which
I have always selected.  Thankfully, the search is working with Mozilla as a
default browser, so I will use Mozilla from now on.

Comment 9

15 years ago
That's what would be expected to happen, Frank. If you're running Mozilla, and
you change your default browser to Netscape (and save the change), then when you
try to follow a search link Netscape will try to launch, and will fail because
Mozilla and Netscape can't run at the same time.

Resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.