Status

()

Core
XUL
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Sam Beale, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20020927
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20020927

Clicking on down scroll arrow starts downward scrolling as it should, but two
problems occur.  If the mouse button is released, scrolling continues.  If the
mouse button is held down, scrolling becomes jumpy.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Stop scrolling imediately when mouse button is released.  Smooth scrolling if
mouse button is held down.

This has been a bug ever since release 1.1

Comment 1

16 years ago
WorksForMe using FizzillaCFM/2002092611 on 10.1.5. Scrolling stops when the
mouse button is released.

Sam, please tell us what specific URL you're viewing when this problem manifests
itself.
Assignee: asa → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asa → jrgm
(Reporter)

Comment 2

16 years ago
It happens on all pages.  Try ftp://ftp.mozilla.org/pub/mozilla/nightly/.  To be
more detailed about the problem, if I click on the top or bottom scroll arrow to
start scrolling and then release the mouse button BUT LEAVE THE CURSOR
POSITIONED OVER THE ARROW, scrolling continues for a second or two or three, I
haven't figured out what triggers it to stop scrolling, but it seems to depend
on page content.  If I move the cursor off the arrow and onto the browser page
itself, scrolling stops immediately.  Also, the latest Mozilla OSX build I've
tried, 2002093010, seems to have somewhat less jumpiness when I hold the mouse
button down on the scrolling arrow.  This jumpiness also seems to depend on the
page content.  FYI, I'm using OSX 10.2.1, but the problems also occurred in
10.2.  The same symptoms occur on an newer iBook and a G4 tower.

Comment 3

16 years ago
Now that I look at this, Sam, you should report these two issues as separate bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.