crashes when opening http://www.delfi.lt

RESOLVED DUPLICATE of bug 179822

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 179822
15 years ago
13 years ago

People

(Reporter: Vytautas Lukenskas, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed with Flash 6], URL)

(Reporter)

Description

15 years ago
latest builds crashes when opening http://www.delfi.lt/ (I've tryed build
2002092704, and some builds before this one, and they all crashed). 
Build 2002091708 and builds before this one are working ok.

Comment 1

15 years ago
please provide a talkback ID for the crash
this does not block Mozilla development
Severity: blocker → critical
Keywords: crash

Comment 2

15 years ago
WFM, Win2K SP3, build 2002091604

Comment 3

15 years ago
WFM on WindowsXP build 2002091014.

Comment 4

15 years ago
do you have flash installed?  if so what version, and if you remove flash, do
you still crash?

Comment 5

15 years ago
do you still crash using latest build ?
http://ftp.mozilla.org/pub/mozilla/nightly/latest
Keywords: stackwanted
(Reporter)

Comment 6

15 years ago
latest build (2002111508 for win32) still crashes on some pages with flash. For
example http://www.anekdot.ru/an/an0211/021118.html

Flash plugin info:

File name: NPSWF32.dll
Shockwave Flash 5.0 r41 
(Reporter)

Comment 7

15 years ago
The same build (2002111508, win32) with Shockwave Flash 6.0 r47 does not crash. 
Anyway, default plugin for flash in netscape plugins page is still ver. 5.0 r41...

Comment 8

15 years ago
Vytautas, can you post Talkback ID for the Flash 5 crash (given you sent
Talkback data when the feedback agent popped up) by running
"mozilla/bin/components/talkback.exe" ?
Whiteboard: [fixed with Flash 6]
(Reporter)

Comment 9

15 years ago
Talkback id for Flash 5 crash: TB14078895G

Comment 10

15 years ago
Tom, can you retreive Talkback data please: TB14078895G ?
Whiteboard: [fixed with Flash 6] → [fixed with Flash 6] TB14078895G

Comment 11

15 years ago
Incident #14078895
-----------------
 MozillaTrunk
 Build ID    2002111508
 OS          Windows NT 5.0 build 2195

0xffff02e9 
NPSWF32.dll + 0xbb7a (0x031dbb7a) 
NPSWF32.dll + 0xae46 (0x031dae46) 
USER32.dll + 0x46fc (0x77e146fc) 
USER32.dll + 0x74ad (0x77e174ad) 
ntdll.dll + 0x202ff (0x77fa02ff) 
nsView::SetDimensions [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 
530] 
nsViewManager::ResizeView 
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2565] 
nsLineLayout::ReflowFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineLayout.cpp, line 1268] 
nsBlockFrame::ReflowInlineFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3902] 
nsBlockFrame::DoReflowInlineFrames 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3730] 
nsBlockFrame::DoReflowInlineFramesAuto 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3634] 
nsBlockFrame::ReflowInlineFrames 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3579] 
nsBlockFrame::ReflowLine 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2653] 
nsBlockFrame::ReflowDirtyLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2297] 
nsBlockFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944] 
nsBlockReflowContext::ReflowBlock 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, line 
537] 
nsBlockFrame::ReflowBlockFrame 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3337] 
nsBlockFrame::ReflowLine 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2519] 
nsBlockFrame::ReflowDirtyLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2297] 
nsBlockFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 944] 
nsContainerFrame::ReflowChild 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 
949] 
CanvasFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsHTMLFrame.cpp, line 570] 
nsBoxToBlockAdaptor::Reflow 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 
929] 
nsBoxToBlockAdaptor::DoLayout 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 
670] 
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 
1066] 
nsScrollBoxFrame::DoLayout 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsScrollBoxFrame.cpp, line 361] 
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 
1066] 
nsBoxFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 900] 
nsContainerFrame::ReflowChild 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 
949] 
ViewportFrame::Reflow 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsViewportFrame.cpp, line 579] 
IncrementalReflow::Dispatch 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 896] 
PresShell::ProcessReflowCommands 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6494] 
PresShell::FlushPendingNotifications 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5169] 
nsDocument::FlushPendingNotifications 
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp, line 3736] 
nsHTMLDocument::FlushPendingNotifications 
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLDocument.cpp, line 
1565] 
nsHTMLExternalObjSH::GetPluginInstance 
[c:/builds/seamonkey/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 5338] 
nsHTMLExternalObjSH::PostCreate 
[c:/builds/seamonkey/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 5399] 
XPCWrappedNative::GetNewOrUsed 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 
418] 
XPCConvert::NativeInterface2JSObject 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp, line 1061] 
nsXPConnect::WrapNative 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 567] 
nsDOMClassInfo::WrapNative 
[c:/builds/seamonkey/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 989] 
nsHTMLDocumentSH::GetProperty 
[c:/builds/seamonkey/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 4957] 
XPC_WN_Helper_GetProperty 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, 
line 802] 
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2549] 
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2640] 
js_Execute [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 1022] 
JS_EvaluateUCScriptForPrincipals [c:/builds/seamonkey/mozilla/js/src/jsapi.c, 
line 3384] 
nsJSContext::EvaluateString 
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 702] 
nsScriptLoader::EvaluateScript 
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 586] 
nsScriptLoader::ProcessRequest 
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 494] 
nsScriptLoader::ProcessScriptElement 
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 438] 
nsHTMLScriptElement::MaybeProcessScript 
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLScriptElement.cpp, 
line 699] 
nsHTMLScriptElement::SetDocument 
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLScriptElement.cpp, 
line 499] 
nsGenericHTMLContainerElement::AppendChildTo 
[c:/builds/seamonkey/mozilla/content/html/content/src/nsGenericHTMLElement.cpp, 
line 4074] 
HTMLContentSink::ProcessSCRIPTTag 
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLContentSink.cpp, 
line 5708] 
HTMLContentSink::AddLeaf 
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLContentSink.cpp, 
line 3708] 
CNavDTD::AddLeaf [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 
3806] 
CNavDTD::HandleScriptToken 
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 2277] 
CNavDTD::OpenContainer [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, 
line 3451] 
CNavDTD::HandleDefaultStartToken 
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 1352] 
CNavDTD::HandleStartToken 
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 1757] 
CNavDTD::HandleToken [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, 
line 913] 
CNavDTD::BuildModel [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, 
line 530] 
Keywords: stackwanted
Whiteboard: [fixed with Flash 6] TB14078895G → [fixed with Flash 6]

Comment 12

15 years ago
This crash is typical of bug 179822.
Eventhough the first crash reported here occurred before the regression noted in
bug 179822, as it's now fixed with Flash 6, I believe it's ok to now mark it
dupe of bug 179822.
Please reopen if I'm wrong.

*** This bug has been marked as a duplicate of 179822 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 13

15 years ago
*** Bug 185023 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.