Composer inserts blank lines within document and <br> tags at end of document

VERIFIED DUPLICATE of bug 159392

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 159392
16 years ago
15 years ago

People

(Reporter: Bill Moore, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
example:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <title>Bill Moore's Daily Log for September 2002</title>
 
</head>
<body background="2backgr.gif">
<h1 align="center">Daily Log for September 2002</h1>
<h2>Thu Sept 26</h2>
<ul>
  <li>checked backup logs   </li>
  <li>added surplus computers to inventory database</li>
  <li>new item - <b>notice the unwanted &lt;br&gt; tag added by the composer</b>
on this line<br>
  </li>
  <li><font color="#009900"><b>also, notice the unwanted &lt;br&gt; tags after
the "summary of week" at and of document</b> . &nbsp;This happens when I
close and reopen the file before I have made any changes.</font></li>
  <li><font color="#009900"><i>I wish the Composer would not string out all
of the preformatted text in one long line of source text.</i></font></li>
  <li><font color="#009900"><b>Although it doesn't happen in this example,
the Composer also inserts unwanted blank lines and spaces in the source, whether
or not I select the "Reformat HTML source" option.</b> &nbsp;The amount of
white space grows every time I close and reopen the file.</font><br>
  </li>
  <li>making final adjustments in PPR form   </li>
  <li>helped Barbara sign up for isis-empl_admin mailing list   </li>
  <li>_can't hear phone in potting house   </li>
  <li>_longer cord for Mrs. Martin in Dr.'s office   </li>
  <li>_work order to cover wires along walkway</li>
</ul>
<pre>summary of week:<br>1::::	monitoring and making disc backups<br>:222:
installing and troubleshooting systems/software/hardware<br>:::::	coding,
compiling, debugging, documenting in-house software<br>:::::	designs and
develops in-house software<br>::11:	writing documentation for users,
operators, and programmers<br>:::::	serving as computer liaison for in-house
software<br>1:1::	analyzing needs and purchasing hardware/software<br>::1::
instructing staff members on how to use computers<br>1332:	help desk duties,
maintenance, inventory, vendor calls<br>:2:2:	routine maintenance of
software<br>:1:1:	routine maintenance of hardware<br>1::::	installation of
network components (cards, cabling, hubs)<br>1::::	attending required
training<br>3::::	installing/maintaining/repairing telecommunication
equipment<br></pre>
<br>
<br>
<br>
</body>
</html>
(Reporter)

Comment 1

16 years ago
Created attachment 100887 [details]
sample file that demonstrates one of the problems

This file demonstrates the problem of <br> tags being added to the end of the
file whenever it is loaded into the Composer.

Comment 2

16 years ago
what build is this problem seen on?  This sounds like a duplicate bug.
If you can reproduce this problem on a build newer than 8/25, please comment
here and reopen bug.

*** This bug has been marked as a duplicate of 159392 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Editor: Composer → Editor: Core
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
You need to log in before you can comment on or make changes to this bug.