Closed Bug 1712123 Opened 5 months ago Closed 21 days ago

Don't tick during the process-switch period

Categories

(Core :: Layout, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
94 Branch
Fission Milestone MVP
Tracking Status
firefox-esr78 --- disabled
firefox-esr91 --- disabled
firefox90 --- disabled
firefox91 --- disabled
firefox92 --- disabled
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: sefeng, Assigned: dholbert)

References

(Blocks 2 open bugs, Regression)

Details

(Whiteboard: fission-soft-blocker)

Attachments

(1 file)

In the profiles that we have collected, ie https://share.firefox.dev/3bW4dkj and https://share.firefox.dev/3bABHoa, we always see the refreshdriver tick during the process switching period. It usually takes about 1-2ms.

We should avoid doing this tick because we don't really need to paint anything. According to some words from Olli, we might want to modify https://searchfox.org/mozilla-central/rev/2f1a015b004b79f1145c81cdf86b15481a5630e2/layout/base/nsRefreshDriver.cpp#1398 to check for page loads.

I think this is a regression from the recent changes which have improved responsiveness.
Should we limit catch-up to happen only after page load?

Severity: -- → S3
Component: DOM: Content Processes → Layout
Priority: -- → P3

Tracking for Fission MVP because this would be a nice to fix performance optimization.

Fission Milestone: --- → MVP

I'll put this on my plate for the moment to take it out of the unassigned queue, though we may find another owner for this.

(Also, if this slips off of the MVP list, I suspect users wouldn't notice too much; it doesn't sound like this is a major perf pain point.)

Assignee: nobody → dholbert
Status: NEW → ASSIGNED

This bug is a soft blocker for Fission MVP. We'd like to fix it before our Release channel rollout, but we won't delay the rollout waiting for it.

Whiteboard: fission-soft-blocker
Regressed by: 1675614
Depends on: 1725133

This bug would still be nice to fix for Fission MVP (Firefox 94) because it might help with the recent warm load regression bug 1722641 from bfcache-in-parent.

The "catch-up" ticks are a strategy to make our repaint cycle more repsonsive
to user interaction, e.g. getting typed characters onto the screen sooner.
During pageload, this strategy isn't as crucial and may in fact harm the
overall pageload performance. So, this patch makes us hold off on these ticks
until after the page has finished loading.

Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5a8c52f0f18
Don't do refresh-driver "catch-up" ticks until after pageload. r=smaug
Status: ASSIGNED → RESOLVED
Closed: 21 days ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Setting status-firefox93=wontfix because we don't need to uplift this tick fix to Beta 93.

You need to log in before you can comment on or make changes to this bug.