televideo.rai.it - using proprietary JS

RESOLVED INVALID

Status

Tech Evangelism Graveyard
Italian
P4
normal
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: Maurilio Venturini, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-JS] [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
loading page
http://www.televideo.rai.it/nazionale/homenaz.asp?tlv=280&sottop=00&x=13&y=8

The box "NAVIGA IN TELEVIDEO" remains blank instead of showing the picture
280_00.jpg (as you can see in IE).

Comment 1

16 years ago
This appears to be a website issue:

They are checking for browser name via:
	var isNav4 = (window.navigator.appName == "Netscape");
and mozilla & its derivatives (ns6/7) get flagged by this.
and so they incorrectly think mozilla is nav4 and then use layers

<SCRIPT LANGUAGE="JavaScript">
if (isNav4) {
        document.layers["tlvNav"].visibility='show';
} else {
        eval('document.all.tlvNav.style.visibility="visible"');
}
</SCRIPT>

the site should be changed to check for mozilla .vs. 4.x .vs. ie
as in http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html

Comment 2

16 years ago
fyi appName is hardcoded as Netscape in routine
NavigatorImpl::GetAppName(nsAString& aAppName)
around line 5470 in nsGlobalWindow.cpp
http://lxr.mozilla.org/seamonkey/source/dom/src/base/nsGlobalWindow.cpp#5470

Comment 3

16 years ago
Re-assigning to evangelism.  If they change their "isNav4" check to
the following, I think things will work.

var isNav4 = (window.navigator.appName == "Netscape") &&
(parseInt(window.navigator.appVersion) <= 4);
Component: Image: Layout → Europe: Central
Product: Browser → Tech Evangelism
Target Milestone: --- → Future
Version: other → unspecified

Comment 4

16 years ago
reassinging to susie
Assignee: pavlov → susiew

Comment 5

16 years ago
Confirming new.
Reducing priority.  Critical is not used for TE bugs.
Severity: critical → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Summary: image not loaded → televideo.rai.it - using proprietary JS
Whiteboard: [PROPRIETARY-JS]
Target Milestone: Future → ---

Comment 6

15 years ago
Moving to new component
Assignee: susiew → italian
Component: Europe: Central → Italian
QA Contact: tpreston → italian
initial problem is fixed, but now their scroller doesn't work and flash anims
are not displayed.
Whiteboard: [PROPRIETARY-JS] → [PROPRIETARY-JS] [bug248549notfixed]

Comment 8

9 years ago
looks like the site might be working ok now
That link 404s now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.