Can not send mail through any SMTP server after adding blank entry

VERIFIED DUPLICATE of bug 146488

Status

--
major
VERIFIED DUPLICATE of bug 146488
16 years ago
14 years ago

People

(Reporter: evanm, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Hi.  I'm using Mozilla 1.1 (Gecko/20020826) and at the moment, I am completely
unable to send outgoing messages via SMTP.  Here's what I believe happened:

First, I tried to add a second SMTP server to my first entry.  I was unable to
close the mail account settings dialog (there's already a bug on this: #167564).
 After killing Mozilla and starting over, I began to play with the Account
Settings dialog, and accidentally added a blank server entry (which shouldn't be
allowed to happen: bug #169366).

I succeeded in adding my correct SMTP server, and that entry appears to be fine.
 I can set it to the default, which is what I want it to do.  However, I can't
send mail.  When I try to send a message, I get the following error:
"Sending of message failed.

An error occured sending mail: Unable to connect to SMTP server %S.  The server
may be down or may be incorrectly configured.  Please verify that your Mail/News
account settings are correct and try again."

Note the %S.  This happens regardless of what SMTP server I have set to use or
set as the default.

I can delete the blank entry, and it stays deleted until I try to send another
message.  At that point, I get the same error message, and the blank entry
reappears in the advanced accounts dialog.  I can edit the blank entry, and put
in correct information for an SMTP server, but I have the same problem; Mozilla
creates a new blank entry, so I now have a total of three entries.

This is reproducable in sense that it always happens, and it is reproducable in
the sense that I can uninstall and reinstall Mozilla and it's still there.  I
don't know if it's reproducable in the sense that if I fix it, I can make it
come  back again by doing the same thing with the blank entry, because I haven't
been able to fix it.

It seems to reside somewhere in the profile, since it sticks around through
reinstalls (and through multiple versions; I tried 1.2a and a nightly from 9/26,
though the nightly had so many other problems I'm not sure whether my problem
still was happening).  I don't particularly want to delete my whole profile. 
Can someone point out the parts of the profile that I can kill to hopefully
reset the SMTP account manager to a working state?

Thanks.


Evan Murphy.  (evanm@caltech.edu)
(Reporter)

Comment 1

16 years ago
Update: I've discovered that I can create a new SMTP account with the correct
info, and then tell a mail account explicitly to use that account instead of the
default, and it will work correctly.  The blank entry doesn't show up when I
send that way, but it still shows up if I try to send to the default SMTP
server, even though the default mail server is set to the same one I explicitly
set in the mail account settings.

Comment 2

16 years ago
this was fixed a while back. You may need to edit your prefs.js
see bug 146488 comment 44. (And keep in mind that mozilla musn't run while you
edit prefs.js.)

*** This bug has been marked as a duplicate of 146488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.