JPGs of type EXIF do not display properly

RESOLVED INVALID

Status

()

Core
ImageLib
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Rick Maddy, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
The above URL points to a JPG whose 'file' output is "DCP_1929.JPG: JPEG image
data, EXIF standard 0.77, 42 x 0"

IE 5.5 renders this JPG just fine.

This problem occurred with Mozilla 1.1 on both Linux and Win2K.

Comment 1

15 years ago
It's a server configuration bug : the webserver send the wrong MIME-type to the
browser (should have been image/jpeg) :

HTTP/1.1 200 OK
Date: Sat, 28 Sep 2002 09:10:52 GMT
Server: Apache/1.3.20 (Unix)
Connection: close
Content-Type: text/html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
OK - try this instead: http://www.maddyhome.com/canardpages/pages/bittner/index.html

Click on the first image to bring up a bigger image. The bigger image has the
problem.

index.html has a simple <img> tag to the "bad" JPG file that Mozilla can't handle.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

15 years ago
*** Bug 171384 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
The first image on http://www.maddyhome.com/canardpages/pages/bittner/index.html
is http://www.maddyhome.com/canardpages/pages/bittner/DCP_1929.JPG
(scaled down to width="320") and it is rendered fine even though it is sent
with the wrong MIME type of "text/html". Clicking on it takes you to the same
image URL (unscaled) but now it is not rendered (as an image). Part of content:
<a href="DCP_1929.JPG"><img src="DCP_1929.JPG" width="320"></a>

My guess is that we interpret the SRC attribute of an IMG element as an image
no matter what the server says. Accessing the image URL directly we use the
MIME type the server sends to tell us what it is.

INVALID?

Comment 5

15 years ago
Rick, gif images also have a bad mime type, please update your web server to
send proper MIME type for images, etc.

Comment 6

15 years ago
file is sent as text/html, mozilla shows it as text/html. that's correct
behaviour...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.