Closed Bug 1713377 Opened 4 months ago Closed 3 months ago

Fetch pure-python wheels if possible when vendoring

Categories

(Firefox Build System :: Mach Core, enhancement, P2)

enhancement

Tracking

(firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: mhentges, Assigned: mhentges)

References

Details

Attachments

(2 files)

Fetching wheels instead of tar.gz files has two benefits:

  1. There's less files, since we just get the "pure" Python and no docs, build files, etc
  2. As we start running the pip resolver against our packages, it needs to be able to understand them, and some packages (like zipp) don't like having setup.py run from the release.
Assignee: nobody → mhentges
Status: NEW → ASSIGNED
Priority: -- → P2

Since we need the raw Python to be available to add to the sys.path,
we extract the wheels before putting them in the tree.
However, you can't pip install an extracted wheel, so
install_pip_package() needed to be tweaked to "re-bundle" the wheel
before installing a vendored package.

sys.path configuration is adjusted for packages who had nested
their python files in their tar.gz artifacts.

Depends on D116511

Attachment #9224528 - Attachment description: Bug 1713377: Vendor pure-python wheels instead of source, if possible → Bug 1713377: Vendor pure-python wheels instead of source, if possible BEFORE

This contains the vendoring changes caused by the
last patch.

For reviewing, there's a couple things to note:

  • A bunch of files are deleted, since there's generally
    less files in a wheel than in a source archive.
  • There's a new .dist.info directory for each
    extracted wheel, so expect roughly 5 or
    6 new files for each wheel'd package.
  • There should be no source code changes other than
    moves from package names changing from having
    - to having _.

Depends on D116512

Attachment #9224528 - Attachment description: Bug 1713377: Vendor pure-python wheels instead of source, if possible BEFORE → Bug 1713377: Change vendoring to use wheels where possible
Depends on: 1713818
Pushed by mhentges@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1537ac197686
Change vendoring to use wheels where possible r=ahal,glandium
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
You need to log in before you can comment on or make changes to this bug.