If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installer does not start - config.ini is missing

VERIFIED FIXED

Status

SeaMonkey
Installer
--
blocker
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Christopher Curzio, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020914
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020914

The installer from the latest nightly does not start. Running
./mozilla-installer just kicks you back to the prompt. Nothing shows up in ps,
and Mozilla is not running when attempting to start the installer. 

Reproducible: Always

Steps to Reproduce:
1. Download today's nightly
2. Attempt to start installation

Actual Results:  
Nothing. 

Expected Results:  
Start the installer.
(Reporter)

Comment 1

15 years ago
Created attachment 100987 [details]
strace of ./mozilla-installer

This is the result of running an strace on the installer. Don't know if it will
help, but there it is.
(Reporter)

Comment 2

15 years ago
Downloaded 1.01 to see if that installer would work, and to make sure this isn't
some weird error with my box. The installer started fine. 

Comment 3

15 years ago
self-extracing or net installer?
conceivably, you picked up the 9-27 21:00:00 build

mozilla-installer is a script, so stracing it doesn't show much.  you need to do
"strace -f" or strace the mozilla-installer-bin (after setting LD_LIBRARY_PATH)

Comment 4

15 years ago
I'm seeing this with 2002-09-28-04-trunk build (self-extracting version).

The installer archive is missing the config.ini file.

stat64("config.ini.C", 0xbffff8ac)      = -1 ENOENT (No such file or directory)
stat64("config.ini", 0xbffff8ac)        = -1 ENOENT (No such file or directory)
_exit(-604)
(Reporter)

Comment 5

15 years ago
Created attachment 100993 [details]
Second strace

I picked up the self-extracting installer. 

Here's the strace from mozilla-installer.bin

Comment 6

15 years ago
Seems it is a packaging error. I downloaded mozilla-i686-pc-linux-gnu-sea.tar, 
in which there was no config.ini file in the mozilla-installer directory, and
the script exited immediately. I copied config.ini from a previous nightly and
was eventually able to install (Build ID: 2002092804).

Comment 7

15 years ago
I'm getting the same with linux trunk build 2002092804

makring NEW
URL: N/A
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Summary: Installer does not start → Installer does not start - config.ini is missing

Updated

15 years ago
QA Contact: bugzilla → ktrina

Comment 8

15 years ago
*** Bug 171526 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
I think there were some changes to config.ini due to TypeAheadFind. May have
caused this?

Workaround is to download 2002092708 build (last working), and change all of the
URL0 lines to point to 2002-09-29-04-trunk

In vim: :%s/2002-09-27-08-trunk/2002-09-29-04-trunk/

Should see confirmation 12 changes were made.

Comment 10

15 years ago
the typeaheadfind is no longer an xpi.  it should be removed from config.ini
(component 11).  See:

http://download.mozilla.org/pub/mozilla/nightly/2002-09-29-04-trunk/linux-xpi/

Comment 11

15 years ago
CCing a few people that might know something about this. I didn't see anything
obviously wrong in the checkins I've had a look at. This is a blocker, please
have a look at it.

Comment 12

15 years ago
the distributed config.ini is not part of CVS.  this is a packaging problem

Comment 13

15 years ago
This should probably me marked a dup of bug 166712, which I reopened. I made
some mistakes which the new patch in there fixes. I'm still seeking sr=dveditz.
Depends on: 166712

Comment 14

15 years ago
I just corrected some of the errors from my checkin to bug 166712 - let me know
if that corrects the problem.

Comment 15

15 years ago
sea installer archive for build 2002100104 is ok.  config.ini is included and
installing works fine.

Comment 16

15 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 17

15 years ago
config.ini in sea and installer builds today.
Status: RESOLVED → VERIFIED
*** Bug 171835 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.