Advanced Search on news only searches in old news

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: gorgonz, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020920
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020920

if i search some news entries just using the standard filter above the pane with
news headers, everythings works fine. if I try the same thing by using the
advanced search, i will receive only results to a certain date in the past,
maybe when i last picked the news.

Reproducible: Always

Steps to Reproduce:
1. Using news.lexware.de
2. getting new headers (500) with leaks in the past
3. activating headerfilter (above the header pane) by entering 'excel'
4. just 3 news are left
5. push clear button to see them all again
6. push advanced button to get advanced search dlg
7. perform search: subject contains 'excel' and activate it with search-button 

Actual Results:  
No result is found

Expected Results:  
finding again those 3 entries

Tried to catch many news with advanced search: subject contains "r", like response

got big result ending at date 08.08.02. No newer matches were found.
(Reporter)

Comment 1

16 years ago
added another test by restarting mozilla -> same result
but:
took another keyword 'lux' like deluxe and got a lot of news with the special
feature: date=01.01.1970 01:00

think this is the representation of date value 0

using the open button to get details of those mails, shows up the date 08.08.02
So here we are. There must a be two kind of dates then. Looks like advanced
search stops reaching date 0, but still knowing the date is 08.08.02 
(Reporter)

Comment 2

16 years ago
did forget something: the 0 date mails also have no subject in the advanced
search result pane. One example has 
subject: Re: Quicken 2000 + T-Online >>> Hallo Firma Lexware und Hotline !!!
date: 08.08.02 15:39

Comment 3

16 years ago
Peter Möller: The 'Advanced Search' button no longer exists (as of 1.3).  I 
tried using Tools|Search Messages and also a customized View (in 1.4) and found 
that both properly located a message that had newly arrived (headers-only 
downloaded).

I am marking this bug WorksForMe -- if you agree, please mark it Verified; if 
not, please contact me via email before reopening.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
its ok to close it. I couldn't reproduce it at moment with lexware, because
Tools|Search Messages produces 'A news (NNTP) error occured: Server failure'.
Tried it with news.mozilla.org instead. Seems to be ok now. If the problem shows
up again, I will open a new bug - based on V1.4
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.