Closed Bug 1713724 Opened 1 year ago Closed 1 year ago

Should abort sending on RCPT error in SmtpClient.jsm

Categories

(MailNews Core :: Networking: SMTP, defect)

defect

Tracking

(thunderbird_esr78 unaffected, thunderbird90 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird90 --- fixed

People

(Reporter: rnons, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1710066 +++

The original emailjs-smtp-client treats RCPT error as soft error, as long as one RCPT succeeded, it will send the mail. We should notify user whenever a RCPT error is received.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/644798fad6f7
Abort sending on RCPT error in SmtpClient.jsm. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9224378 [details]
Bug 1713724 - Abort sending on RCPT error in SmtpClient.jsm. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1661694
User impact if declined: When sending to multiple recipients, sending is not aborted on RCPT error, user won't notice some recipients failed.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9224378 - Flags: approval-comm-beta?

Comment on attachment 9224378 [details]
Bug 1713724 - Abort sending on RCPT error in SmtpClient.jsm. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9224378 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.