Closed Bug 1713778 Opened 2 years ago Closed 1 year ago

ntp_text theme property does not change the font color of the new tab page

Categories

(Firefox :: New Tab Page, defect, P3)

defect

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- verified

People

(Reporter: robwu, Assigned: amy)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 obsolete file)

STR:

  1. Visit https://color.firefox.com and install the extension.
  2. Go to the "Advanced colors" tab and set "New Tab Background Color" to a red color and "New Tab Text" to white.
  3. Open a new tab
  4. Look at the colors

Expected:

  • The background should be red.
  • The text on the background (e.g. "Recommended by Pocket" and the text of the tiles) should be white.

Actual:

  • The background is red as expected.
  • The text is still black.

This is a regression from bug 1686384, because it introduced the --newtab-background-primary-text-color CSS variable without mirroring the extension-defined ntp_text to it.

The unit tests at browser_ext_themes_ntp_colors.js and browser_ext_themes_ntp_colors_perwindow.js did not catch this because we don't have test coverage for this specific aspect.

See Also: → 1697196

Any chance you or someone working on newtab can look at this regression?

Severity: -- → S3
Flags: needinfo?(ericaewright)
Priority: -- → P3

(In reply to Shane Caraveo (:mixedpuppy) from comment #1)

Any chance you or someone working on newtab can look at this regression?
I'm not sure who is on newtab anymore, I'm no longer working at Moz.

Flags: needinfo?(ericaewright) → needinfo?(mixedpuppy)
Flags: needinfo?(mixedpuppy) → needinfo?(sdowne)

Amy this is probably something that is worth looking at from a newtab triage point of view.

I also think it might make sense to move this into the newtab or topsites component, too?

Flags: needinfo?(sdowne) → needinfo?(achurchwell)
Component: Themes → New Tab Page
Flags: needinfo?(achurchwell)
Product: WebExtensions → Firefox

Like comment 0 said, new-new-tab introduced the variable --newtab-background-primary-text-color which is not themeable. It replaced --newtab-text-primary-color in some cases, which is themeable. We should consider this in bug 1727317.

Depends on: 1727317
Assignee: nobody → achurchwell
Attachment #9241028 - Attachment description: Bug 1713778, 1727317 Define the relationships between new tab CSS variables. r=harry! [WIP] → WIP: Bug 1713778, 1727317 Define the relationships between new tab CSS variables. r=harry!

This will be fixed in bug 1727319.

Depends on: 1727319

Bug 1727319 landed.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

This issue was part of the work done on QA-1182 request. Considering this I am marking it as Verified.

Status: RESOLVED → VERIFIED
Attachment #9241028 - Attachment is obsolete: true
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.