Closed Bug 1713787 Opened 6 months ago Closed 6 months ago

Fix some CSS-variables tests.

Categories

(Core :: CSS Parsing and Computation, defect)

defect

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(3 files)

No description provided.
Summary: Fix expectations of some CSS-variables tests. → Fix some CSS-variables tests.

Custom properties are white-space aware and should preserve input, so
the expectation is wrong. In order for serialization to roundtrip you
can't add an space after the colon.

These tests are not right, they are expecting untyped custom properties
to transition, and that's not how these work.

All browsers time out:

https://wpt.fyi/results/css/css-variables?label=master&label=experimental&aligned

So we should just remove them IMO.

Depends on D116460

Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ff00c885d96
Remove some tests that time out in all browsers. r=boris
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29188 for changes under testing/web-platform/tests
Attachment #9224416 - Attachment description: Bug 1713787 - Fix expectations of two css-variables tests. r=#style → Bug 1713787 - Fix whitespace handling inside CSS variables. r=#style
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0eff98b29ec0
Make custom properties that are IACVT guaranteed-invalid. r=boris
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2dc1eff1effd
Fix whitespace handling inside CSS variables. r=xidorn
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/1ddacb243ae6
Fix test_variable_serialization_computed.html
Upstream PR merged by moz-wptsync-bot
Attachment #9224416 - Attachment description: Bug 1713787 - Fix whitespace handling inside CSS variables. r=#style → Bug 1713787 - Fix whitespace handling inside CSS variables. r=xidorn
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d55d07d3e8cc
Fix whitespace handling inside CSS variables. r=xidorn
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29255 for changes under testing/web-platform/tests
Keywords: leave-open
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Upstream PR merged by moz-wptsync-bot
Duplicate of this bug: 1717272
You need to log in before you can comment on or make changes to this bug.