impossible to download a file and save it or open it

RESOLVED DUPLICATE of bug 166369

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED DUPLICATE of bug 166369
15 years ago
13 years ago

People

(Reporter: flavia liberatore, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910

If i try to download certain files.For example "Syncronize Pro 1.2.5" from
Versiontracker)the file can not be automatically open by stuffit expander. If I
save it on HD it is shown as a file hqx , but there is no way to open it. 
The same file is handeled perfectly by explorer,downloaded in the same moment
from the same URL , and it is not shown as hqx but as sit.
Same with many other files I tried to download

Reproducible: Always

Steps to Reproduce:
1.go to: http://www.versiontracker.com/macosx/
2.Try to download and open or to download and save on disk,than open the
file"synchronize Pro".
3.

Actual Results:  
Noting happens...the fil just does not open.

Expected Results:  
to open it with stuffit expander or to save a file that should be a sit file
instead than hqx and that should be possible to open with stuffit.

Comment 1

15 years ago
sit/hqx related things are discussed in bug 147804. Especially the bugs linked
to in bug 147804 comment #10 and #9 might be interesting...

Comment 2

15 years ago
WorksForMe using FizzillaCFM/2002092611 on 10.1.5. The server deliveres the file
with the right MIME type (application/mac-binhex40), Mozilla offers to
automatically open it using StuffIt Expander, and Expander postprocesses it just
fine.
QA Contact: sairuh → petersen

Comment 3

15 years ago
I'm seeing the problem with Fizilla 1.2b 2002101612 on Mac OS X 10.2

In my case the files can be double-clicked afterwards and Stuffit Expander
processes them normally, so it seems to be just the step of sending the command
to open the file that is busted. 

The problem also seems to be intermittent. The "synchronize pro" file mentioned
here downloaded and opened in Stuffit automatically, but only a few minutes ago
a BBEdit update generated the error message that the file "could not be opened
because an unknown error occured" (followed by an apology and a suggestion to
save instead). I downloaded both files within minutes of each other, without
restarting Mozilla or doing anything other than a bugzilla search. 

Comment 4

15 years ago
flavia, can you still reproduce this problem using a current nightly build?

Comment 5

14 years ago
Running 1.5.1 on OS 10.1, Mozilla refuses to save the file.

Reproducable always.

Comment 6

14 years ago
Please try Mozilla 1.7 RC1 or later. Does the problem still occur?

Comment 7

13 years ago
95% likely this is the HFS paths bug.
If this still happens to you in 1.6 or later, let us know to reopen.

*** This bug has been marked as a duplicate of 166369 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.