Closed Bug 1713908 Opened 3 years ago Closed 3 years ago

Tests skipped in 'gfx/layers/apz/test/mochitest/browser.ini' for new Fission platform triage

Categories

(Core :: Panning and Zooming, task)

task

Tracking

()

RESOLVED FIXED
91 Branch
Fission Milestone M7a
Tracking Status
firefox-esr78 --- disabled
firefox89 --- disabled
firefox90 --- disabled
firefox91 --- fixed

People

(Reporter: ahal, Assigned: hiro)

References

Details

Attachments

(1 file)

The following tests were disabled in gfx/layers/apz/test/mochitest/browser.ini due to new Fission platform triage:
browser_test_select_popup_position.js

Full diff:

diff --git a/gfx/layers/apz/test/mochitest/browser.ini b/gfx/layers/apz/test/mochitest/browser.ini
--- a/gfx/layers/apz/test/mochitest/browser.ini
+++ b/gfx/layers/apz/test/mochitest/browser.ini
@@ -16,16 +16,17 @@ support-files =
   FissionTestHelperChild.jsm
   helper_fission_*.*
   !/dom/animation/test/testcommon.js
 [browser_test_select_zoom.js]
 skip-if = (os == 'win') # bug 1495580
 support-files =
   helper_test_select_zoom.html
 [browser_test_select_popup_position.js]
+skip-if = fission && os == "mac" && !debug  # New platform triage
 support-files =
   helper_test_select_popup_position.html
   helper_test_select_popup_position_transformed_in_parent.html
   helper_test_select_popup_position_zoomed.html
 [browser_test_background_tab_scroll.js]
 skip-if = (toolkit == 'android') # wheel events not supported on mobile
 support-files =
   helper_background_tab_scroll.html

See the following try push for failures:
https://treeherder.mozilla.org/jobs?repo=try&revision=ad7a18fdad3b8e35b44152c16d94babb80387cd8

To run these failures in your own try push, first revert the skip-if
annotations, then run:

$ ./mach try fuzzy --rebuild 3 gfx/layers/apz/test/mochitest/browser.ini

Then use the fuzzy interface to select the task(s) which are relevant to the
removed skip-if expression(s). Please note the failure may be intermittent
and/or been fixed since the triage took place.

I don't see the test failures in opt runs in the try push link in comment 0. Whereas I see a failure on debug runs and the failure is same as existing intermittent (bug 1702499).

:ahal, is the link you posted a different one?

Flags: needinfo?(ahal)

We need to determine whether this browser-chrome test failure should block shipping Fission. Tracking for Fission Milestone M7a for the initial audit. Then we can decide whether to move this bug to Fission M8 or post-MVP (Fission Future).

Here is a recent Try run for Fission browser-chrome:

https://treeherder.mozilla.org/jobs?repo=try&revision=ad7a18fdad3b8e35b44152c16d94babb80387cd8

Blocks: 1694824
Fission Milestone: --- → M7a

Thanks for following-up! Short answer: If we can't reproduce anymore, let's use this bug to remove the annotation.

Longer answer:
Enabling new platforms is messy. In this case there were dozens of failures, pre-existing intermittents and the patch was created over the span of weeks. To get coverage on these platforms ASAP, I was also erring on the side of over-disabling when in doubt. So it's possible I either made a mistake, the problem was fixed between now and when I first annotated the manifest, or the test is intermittent and just happened to not fail on these three tasks. I added a few more retriggers to verify.

This bug was filed via script (first time being used), so the process is still being ironed out. I'll adjust the template in the script to make it more clear that A) this is automated, and B) what to do if the failure is not reproducible.

Thanks for understanding!

Flags: needinfo?(ahal)

Assigning to myself to be less confusing and actually I audited there is no APZ test failures in the last try run (in comment 2) and there is one test failure which could be potentially related to APZ (it's more likely to be an issue in IPC stuff) but it's a known intermittent (bug 1702499). So I am closing this bug as INVALID.

Assignee: nobody → hikezoe.birchill
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
See Also: → 1709460

I meant bug 1702499. sorry for confusing.

See Also: 17094601702499

If I'm understanding correctly the test is currently disabled with fission on trunk

https://searchfox.org/mozilla-central/rev/bf8d5de8528036c09590009720bc172882845b80/gfx/layers/apz/test/mochitest/browser.ini#25

so if we just think it's a normal intermitent we want to remove that annotation.

Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Thank you Timothy for the correction. I wasn't aware of the change at all. Actually at the time of the try run in comment 0, it wasn't disabled;
https://hg.mozilla.org/try/file/ad7a18fdad3b8e35b44152c16d94babb80387cd8/gfx/layers/apz/test/mochitest/browser.ini

I will push a new try run with removing the skip-if line.

Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/890ef730194d
Re-enable gfx/layers/apz/test/mochitest/browser_test_select_popup_position.js for fission. r=hiro
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: