Closed Bug 1713958 Opened 8 months ago Closed 7 months ago

System Theme Not Updated In Firefox 89

Categories

(Toolkit :: Add-ons Manager, defect)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1708717
Tracking Status
firefox89 --- affected
firefox90 --- affected
firefox91 --- affected

People

(Reporter: koenigseggcc, Unassigned)

References

Details

Attachments

(4 files)

Attached image addons manager.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Firefox 89 released with a new system design on June 1 2021. However, if you look at the themes in the addon manager:

  1. the update date is still Oct 30 2020
  2. the design reflects what is seen in Firefox 88, and older

Actual results:

See attachment 'addons manager'

Expected results:

At the least, I expect the theme picture to reflect the actual design in Firefox 89. See attachment 'toolbar' as an example.

Attached image toolbar.png
Type: enhancement → defect

The Bugbug bot thinks this bug should belong to the 'Toolkit::Add-ons Manager' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Hello,

I’ve checked the latest Nightly (91.0a1/20210602214447), Beta (90.0b1/20210601190019) and Release (89.0/20210527174632) under Windows 10 x64 and Ubuntu 16.04 LTS.

The system theme preview should be indeed updated to match the current design. So for this reason I will set the issue to New.

I what concerns the last update date mentioned on the details page of the theme, I believe it’s indicative of the date when the used profile was created.
For example, in screenshot 1, the last update date is June 3 2021, which coincides with the date I created the profile that is being used.
In screenshot 2, the last update date is May 24 2021, even though I updated the browser to the latest version just before taking the screenshot. Note that the profile was created on the 24th of May.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached image screenshot1.png
Attached image screenshot2.png
Duplicate of this bug: 1714301
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1708717
You need to log in before you can comment on or make changes to this bug.