Closed Bug 1714068 Opened 4 months ago Closed 3 months ago

Sync vendored puppeteer to v10.0.0

Categories

(Remote Protocol :: Agent, task, P2)

task
Points:
2

Tracking

(firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: whimboo, Assigned: jdescottes)

References

Details

(Whiteboard: [bidi-m1-mvp] )

Attachments

(1 file)

Version 10.0.0 is the most recent release:
https://github.com/puppeteer/puppeteer/releases/tag/v10.0.0

Sadly the Node.js 10 is no longer supported. is a breaking change for us. Our in-tree version of Node is 10.x LTS, and it hasn't been upgraded to Node 12.x LTS yet.

As such we are blocked on bug 1690377 for any further syncs. :( Maybe we could just sync to version 9.0 as covered on bug 1707588.

See Also: → 1707588
Whiteboard: [bidi-m1-mvp]
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Points: --- → 2
Priority: -- → P3
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07cd772813c3
Bug 1707588 - [puppeteer] Sync vendored puppeteer to v10.0.0 r=webdriver-reviewers,whimboo
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Priority: P3 → P2
You need to log in before you can comment on or make changes to this bug.