Closed Bug 171407 Opened 20 years ago Closed 20 years ago

the mail "file save-as" feature does not work for multiple messages

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 58140

People

(Reporter: 2esses, Assigned: sspitzer)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020928
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020928

altho this feature works well for single messages, when multiple messages are
selected, the secondary menu appears as "read-only" and doesn't allow the save
parameters to be entered.  see attached graphic.

Reproducible: Always

Steps to Reproduce:
1.  select a message folder
2.  highlight more than one message
3.  select drop-down menu "file"
4.  select "save-as"

Actual Results:  
a secondary menu appears querying for either "file" or "template".  However, it
will not accept input.  Therefore the job cannot be completed.

Expected Results:  
activate this menu for multiple messages (as previously allowed in older
versions), or at least provide an err-message of why this function cannot proceed.
Attached image screen print
I am seeing a very similar version of this bug in 
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2a) Gecko/20020905.
I CAN select either file or template in the save-as submenu, 
but they do not do anything. The only workaround I can see
is to forward multiple messages as a bunch
of attachments in a single message to yourself. The you can
select "save all" in the attachments pane. Voila-- all of
them get saved to a single file.
I believe the reason for this bug is that Mozilla uses a default name of 
"message.eml" for the file; saving multiple messages would require specifying 
multiple file names, and so displaying the file-select dialog multiple times.  
It therefore is not that much more of an inconvenience, and arguably safer, to 
require individual Save As for each message (which can be done via the context 
menu for the message, as well as the dropdown).

Even if Mozilla saved mail by default according to the Subj: line, there is a 
potential for conflict -- in fact, as a group of messages being saved would 
likely all have the same subject.

If you wanted to save the group as a single file, there is a workaround for 
that: create a new folder, then copy (or move) the messages to that folder: the 
folder is stored as a single file, which you can copy from the Mail directory in 
your profile to use for whatever you need a file for.

And that last point really is the crux of the issue: mail management is much 
easier within the mail client than dealing with files.  Nearly any use of a 
message as a file, external to the program, can be handled as well or better 
within the client.  The program is working as designed, and I think logically; I 
recommend marking this bug Invalid.

(As for Templates, if you really want to save multiple messages as a template, 
you can select Copy To | <account> | Templates, from the context menu or the 
Message dropdown menu, when multiple messages are selected.)
If you use Netscape, a file name is requested when coping multiple files.
Netscape will not use a default file name for a multiple copy.

The ability in netscape is very functional and usable. Because I use it so much,
it is my reason for not moving from Netscape to Mozilla for News and Mail. The
question is always asked; "why move to a new application if the application has
less capability?"

Not moving the feature from Netscape to Mozilla should be considered a reduction
in previous capability, and not so easily dismissed.
I think that Mike Cowperthwaite's response is a "copout" for a bug that's been
around and unresolved since October 20000 #58140.  It should not be his decision
whether I wish to save messages in a file format.  Other email system can do it.
 Mozilla should also have this feature -- by now!
> Mozilla should also have this feature -- by now!

S.Green: it's very nice your offer to fix this bug right now, I'm sure everyone
will be pleased to see your code.

Meanwhile, this is a dup.

*** This bug has been marked as a duplicate of 58140 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.