Closed Bug 1714136 Opened 6 months ago Closed 5 months ago

Replace context menu icons with text

Categories

(Firefox :: Menus, enhancement)

Firefox 91
enhancement

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox89 --- affected
firefox90 --- affected
firefox91 --- affected

People

(Reporter: joshas, Unassigned)

References

Details

(Whiteboard: [proton-context-menus])

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

Open context menu (right click) on any page. Linux OS.

Actual results:

On top row of context menu back, forward, reload and bookmark actions are represented with icons.

Expected results:

With latest removal of icons from main menu it would be appropriate to replace context menu action icons with text entries. It is already done on macOS version.

The Bugbug bot thinks this bug should belong to the 'Firefox::Menus' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Menus

I was able to reproduce it on the latest versions of Firefox using Ubuntu 20. On MacOS 11 with the latest beta and Nightly, the mentioned options from context menu are displayed with text entries. This could be an enhancement. I'll let the dev team to get an opinion on this.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Type: defect → enhancement
Ever confirmed: true
Whiteboard: [proton-context-menus]

We explicitly considered this and decided not to, to save (vertical) space. The reason we did it on macOS is because we now use fully native APIs to render the menu, and they do not support iconified buttons like this.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX

Why not use native menus on other platforms too? Currently context menus on Linux are looking out of place, considering main menu has rounded borders, but context menus were left with straight rectangle corners.

(In reply to joshas from comment #4)

Why not use native menus on other platforms too?

At least on Windows, because win32 APIs do not provide any "nice" menus, and Windows 10/11 itself is confused about what menus are supposed to look like.

I can't speak to the situation on Linux; we use some of the relevant gtk/x11/wayland APIs, but I don't know if there is a higher-level linux context menu solution that we "should" use that supports all the features we need. For sure it'd be a significant investment.

Currently context menus on Linux are looking out of place, considering main menu has rounded borders, but context menus were left with straight rectangle corners.

This is bug 1706378.

You need to log in before you can comment on or make changes to this bug.