Closed Bug 1714178 Opened 6 months ago Closed 6 months ago

`mach try fuzzy` hard codes "autoland" and "mozilla-central" as the project in target_tasks method

Categories

(Firefox Build System :: Task Configuration, defect, P3)

defect

Tracking

(firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(2 files)

When generating tasks to display in the fuzzy interface, this target tasks method is used:
https://searchfox.org/mozilla-central/rev/74f3c420ee54001059e1850bef3be876749ff873/taskcluster/taskgraph/target_tasks.py#339

Since the project is hardcoded, it means that you'll always get the set of tasks relevant to autoland + central, even if you pass in ./mach try fuzzy -p project=mozilla-beta for instance. We should take the proper target tasks into account for the given parameters.

Fixing this will be especially useful for developers working on project branches (which often have much more extreme differences with what runs on trunk).

Note, if we want to do this properly, we'll have to call the actual target_tasks method of the project in question. Otherwise we'll miss most of the filtering that e.g project branches do.

Assignee: nobody → ahal
Status: NEW → ASSIGNED
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/043dc5c902c4
Reuse 'target_tasks_default' in tryselect target tasks methods, r=taskgraph-reviewers,aki
https://hg.mozilla.org/integration/autoland/rev/75e97973d032
Don't hardcode the project to 'autoland/central' in 'try_select_tasks', r=taskgraph-reviewers,aki
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Regressions: 1717691
You need to log in before you can comment on or make changes to this bug.