table does not consisently resize when stylesheets are changed programmatically.

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: ibl, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

in the page at http://www.cs.odu.edu/~ibl/bugzilla.html, the table is
programmatically resized by applying stylesheets.  The sheet is selected by
using the links in the bar at the top of the page.  The stylesheets basically
change the font size.  The table should automatically resize when the font size
is changed.  Sometimes it resizes but mostly not, so the text spills out of the
confines of the table.  The font size, however, does resize properly.

This displays as I want in IE 5.5 and 6.0

Reproducible: Always

Steps to Reproduce:
1.go to http://www.cs.odu.edu/~ibl/bugzilla.html
2. click on XXsmall
3. Click on Medium
play with it

Actual Results:  
The table did not resize when the font resized as the new style sheet was applied

Expected Results:  
The table should have resized to accomodate the font resizing.
Confirmed in 1.1 final. Can someone test this on a nightly?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed in today's nightly on Linux.  This is a table reflow problem, looks like.
Assignee: dbaron → karnaze
Component: Style System → HTMLTables
OS: Windows 2000 → All
QA Contact: ian → amar
Hardware: PC → All

Updated

16 years ago
Priority: -- → P3
Bulk setting karnaze's P2-P5 bugs to future
Target Milestone: --- → Future

Comment 4

16 years ago
mass reassign to default owner
Assignee: karnaze → table
QA Contact: amar → madhur
Target Milestone: Future → ---
Target Milestone: --- → Future
This worksforme in a current build; one of bernd's changes to style change
reflow handling in tables must have fixed this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.