Installer doesn't complete under XP Home.

VERIFIED DUPLICATE of bug 167515

Status

SeaMonkey
Installer
--
blocker
VERIFIED DUPLICATE of bug 167515
16 years ago
14 years ago

People

(Reporter: Pez Mohr, Assigned: dveditz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
Build Identifier: All versions

The installer crashes when installing under Compaq OEM version of XP home.
DrWatson32 says the problem lies within jar50.dll. Running the installer under
Compatability Mode for Windows 2000 seesm to completely resolve the issue.

Reproducible: Always

Steps to Reproduce:
1. Run the installer for any verison under Compaq OEM version of XP Home (All
version of XP may be affected the same way.)

Actual Results:  
The installer crashes with an error message from DrWatson32 blaming jar50.dll

Expected Results:  
The installer should have finished the installation.

<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="SETUP.EXE" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="SETUP.EXE" SIZE="231728" CHECKSUM="0xFAA3EFBF"
BIN_FILE_VERSION="1.0.0.2" BIN_PRODUCT_VERSION="1.0.0.2" PRODUCT_VERSION="1, 0,
0, 2" FILE_DESCRIPTION="setup" COMPANY_NAME="mozilla.org" PRODUCT_NAME="Mozilla
Setup" FILE_VERSION="1, 0, 0, 2" ORIGINAL_FILENAME="setup.exe"
INTERNAL_NAME="setup" LEGAL_COPYRIGHT="Copyright © 2001" VERFILEDATEHI="0x0"
VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x1" MODULE_TYPE="WIN32"
PE_CHECKSUM="0x4048F" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.0.2"
UPTO_BIN_PRODUCT_VERSION="1.0.0.2" LINK_DATE="09/10/2002 22:30:58"
UPTO_LINK_DATE="09/10/2002 22:30:58" VER_LANGUAGE="English (United States)
[0x409]" />
    <MATCHING_FILE NAME="SETUPRSC.DLL" SIZE="153472" CHECKSUM="0x4981FE70"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x34BFF" LINKER_VERSION="0x0"
LINK_DATE="09/10/2002 23:22:35" UPTO_LINK_DATE="09/10/2002 23:22:35" />
    <MATCHING_FILE NAME="xpcom.ns\bin\js3250.dll" SIZE="326576"
CHECKSUM="0x8F12C32D" BIN_FILE_VERSION="4.0.0.0" BIN_PRODUCT_VERSION="4.0.0.0"
PRODUCT_VERSION="4.0" FILE_DESCRIPTION="Netscape 32-bit JavaScript Module"
COMPANY_NAME="Netscape Communications Corporation" PRODUCT_NAME="NETSCAPE"
FILE_VERSION="4.0" ORIGINAL_FILENAME="js3240.dll" INTERNAL_NAME="JS3240"
LEGAL_COPYRIGHT="Copyright Netscape Communications. 1994-96" VERFILEDATEHI="0x0"
VERFILEDATELO="0x0" VERFILEOS="0x10004" VERFILETYPE="0x2" MODULE_TYPE="WIN32"
PE_CHECKSUM="0x551E8" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="4.0.0.0"
UPTO_BIN_PRODUCT_VERSION="4.0.0.0" LINK_DATE="09/10/2002 23:22:31"
UPTO_LINK_DATE="09/10/2002 23:22:31" VER_LANGUAGE="English (United States)
[0x409]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\nspr4.dll" SIZE="160304"
CHECKSUM="0x4E5A845" BIN_FILE_VERSION="4.2.1.0" BIN_PRODUCT_VERSION="4.2.1.0"
PRODUCT_VERSION="4.2.1" FILE_DESCRIPTION="NSPR Library" COMPANY_NAME="Netscape
Communications Corporation" PRODUCT_NAME="Netscape Portable Runtime"
FILE_VERSION="4.2.1" ORIGINAL_FILENAME="nspr4.dll" INTERNAL_NAME="nspr4"
LEGAL_COPYRIGHT="Copyright © 1996-2000 Netscape Communications Corporation"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x30256" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="4.2.1.0" UPTO_BIN_PRODUCT_VERSION="4.2.1.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="English (United States) [0x409]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\plc4.dll" SIZE="29792"
CHECKSUM="0x36D7CDD5" BIN_FILE_VERSION="4.2.1.0" BIN_PRODUCT_VERSION="4.2.1.0"
PRODUCT_VERSION="4.2.1" FILE_DESCRIPTION="PLC Library" COMPANY_NAME="Netscape
Communications Corporation" PRODUCT_NAME="Netscape Portable Runtime"
FILE_VERSION="4.2.1" ORIGINAL_FILENAME="plc4.dll" INTERNAL_NAME="plc4"
LEGAL_COPYRIGHT="Copyright © 1996-2000 Netscape Communications Corporation"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0xADAB" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="4.2.1.0" UPTO_BIN_PRODUCT_VERSION="4.2.1.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="English (United States) [0x409]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\plds4.dll" SIZE="25424"
CHECKSUM="0xEEFF1127" BIN_FILE_VERSION="4.2.1.0" BIN_PRODUCT_VERSION="4.2.1.0"
PRODUCT_VERSION="4.2.1" FILE_DESCRIPTION="PLDS Library" COMPANY_NAME="Netscape
Communications Corporation" PRODUCT_NAME="Netscape Portable Runtime"
FILE_VERSION="4.2.1" ORIGINAL_FILENAME="plds4.dll" INTERNAL_NAME="plds4"
LEGAL_COPYRIGHT="Copyright © 1996-2000 Netscape Communications Corporation"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0xBDAF" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="4.2.1.0" UPTO_BIN_PRODUCT_VERSION="4.2.1.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="English (United States) [0x409]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\xpcom.dll" SIZE="516144"
CHECKSUM="0x1FB68E44" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="xpcom" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x7F7B2" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:33" UPTO_LINK_DATE="09/10/2002 23:22:33"
VER_LANGUAGE="Language Neutral [0x0]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\xpistub.dll" SIZE="7664"
CHECKSUM="0x299DA349" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="xpistub" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x10625" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:33" UPTO_LINK_DATE="09/10/2002 23:22:33"
VER_LANGUAGE="Language Neutral [0x0]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\zlib.dll" SIZE="39088"
CHECKSUM="0x9C222A80" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="zlib" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0xD23F" LINKER_VERSION="0x1000D"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="Language Neutral [0x0]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\components\jar50.dll" SIZE="28864"
CHECKSUM="0xF1A47841" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="jar" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x12FF6" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="Language Neutral [0x0]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\components\ucharuti.dll" SIZE="19904"
CHECKSUM="0xC842EDC7" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="unicharutil" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x8FC7" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:31" UPTO_LINK_DATE="09/10/2002 23:22:31"
VER_LANGUAGE="Language Neutral [0x0]" />
    <MATCHING_FILE NAME="xpcom.ns\bin\components\xpinstal.dll" SIZE="137200"
CHECKSUM="0xF767CED1" BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0"
PRODUCT_VERSION="1.1b" FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape"
PRODUCT_NAME="Mozilla" FILE_VERSION="1.1b" ORIGINAL_FILENAME=""
INTERNAL_NAME="xpinstall" LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1"
VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2"
MODULE_TYPE="WIN32" PE_CHECKSUM="0x2EDB2" LINKER_VERSION="0x0"
UPTO_BIN_FILE_VERSION="1.1.0.0" UPTO_BIN_PRODUCT_VERSION="1.1.0.0"
LINK_DATE="09/10/2002 23:22:32" UPTO_LINK_DATE="09/10/2002 23:22:32"
VER_LANGUAGE="Language Neutral [0x0]" />
</EXE>
<EXE NAME="jar50.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="jar50.dll" SIZE="28864" CHECKSUM="0xF1A47841"
BIN_FILE_VERSION="1.1.0.0" BIN_PRODUCT_VERSION="1.1.0.0" PRODUCT_VERSION="1.1b"
FILE_DESCRIPTION="" COMPANY_NAME="Mozilla, Netscape" PRODUCT_NAME="Mozilla"
FILE_VERSION="1.1b" ORIGINAL_FILENAME="" INTERNAL_NAME="jar"
LEGAL_COPYRIGHT="License: MPL 1.1/GPL 2.0/LGPL 2.1" VERFILEDATEHI="0x0"
VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32"
PE_CHECKSUM="0x12FF6" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.1.0.0"
UPTO_BIN_PRODUCT_VERSION="1.1.0.0" LINK_DATE="09/10/2002 23:22:31"
UPTO_LINK_DATE="09/10/2002 23:22:31" VER_LANGUAGE="Language Neutral [0x0]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" SIZE="930304" CHECKSUM="0xCBCCF8A9"
BIN_FILE_VERSION="5.1.2600.1106" BIN_PRODUCT_VERSION="5.1.2600.1106"
PRODUCT_VERSION="5.1.2600.1106" FILE_DESCRIPTION="Windows NT BASE API Client
DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows®
Operating System" FILE_VERSION="5.1.2600.1106 (xpsp1.020828-1920)"
ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="©
Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0"
VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32"
PE_CHECKSUM="0xE7ED3" LINKER_VERSION="0x50001"
UPTO_BIN_FILE_VERSION="5.1.2600.1106" UPTO_BIN_PRODUCT_VERSION="5.1.2600.1106"
LINK_DATE="08/29/2002 10:40:40" UPTO_LINK_DATE="08/29/2002 10:40:40"
VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>

Comment 1

16 years ago
Is this related to bug 167515 ?

Comment 2

16 years ago
Reporter said:
> Running the installer under
> Compatability Mode for Windows 2000 seesm to completely resolve the issue.

This indicates the same problem as in bug 167515

*** This bug has been marked as a duplicate of 167515 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Is not duplicate os 167515. This is jar50.dll, 167515 is zlib.dll
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

16 years ago
Created attachment 101027 [details]
Error log for installer crash

This is the error log created from the crash of the Mozilla Installer under XP.
(Assignee)

Comment 5

16 years ago
bug 167515 is "Win XP SP1 path rule change hosed installer", zlib is just a
common victim. The fact that compatibility mode makes it work is the clincher.

*** This bug has been marked as a duplicate of 167515 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
v dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.