Closed Bug 1714507 Opened 6 months ago Closed 3 months ago

[Win 8.1] Titles on tabs are barely visible if the browser is unfocused while dark theme is set

Categories

(Firefox :: Theme, defect, P3)

Desktop
Windows 8.1
defect
Points:
1

Tracking

()

RESOLVED FIXED
94 Branch
Iteration:
93.2 - Aug 23 - Sep 5
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- fixed
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- fixed
firefox94 --- fixed

People

(Reporter: csasca, Assigned: harry)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [proton-tabs-bar])

Attachments

(2 files, 1 obsolete file)

Attached image text not visible.gif

Affected versions

  • Firefox 90.0b3
  • Firefox 91.0a1

Affected platforms

  • Windows 8.1

Steps to reproduce

  1. Launch Firefox
  2. Enter customize mode and set the dark theme
  3. Unfocus the browser

Expected result

  • Titles are visible on tabs if the browser is unfocused

Actual result

  • Titles on tabs are barely visible if the browser is unfocused

Regression range

  • Will see for a regression

Additional notes

  • The issue can be seen in the attachment
Has Regression Range: --- → no
Has STR: --- → yes
QA Whiteboard: [qa-regression-triage]
Priority: -- → P3
Whiteboard: [proton-tabs-bar]

Do you have a regression range yet?

Component: Toolbars and Customization → Theme
Flags: needinfo?(catalin.sasca)

The component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
Priority: -- → P3

Here's the regression for this between 2021-04-06 and 2021-04-07

Bug 1700109 - Enable main Proton pref by default in Nightly

This sets browser.proton.enabled to true by default in Nightly. This is the first
wave of Proton changes.

Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=edf8a5f5141f4603a0494a5a7ce377514c1f6ff4&tochange=90a48858e199adfa16947c311265da00be93ccfd

Has Regression Range: no → yes
Flags: needinfo?(catalin.sasca)

(In reply to Catalin Sasca, QA [:csasca] from comment #3)

Here's the regression for this between 2021-04-06 and 2021-04-07

Can you please try bisecting with the browser.proton.enabled pref set to true to find the actual culprit?

Flags: needinfo?(catalin.sasca)

Sure thing, so after bisecting, it seems that there were some changes on toolbar between 2021-03-26 and 2021-03-27. While on builds from 26 and before, the toolbar will look like in the attachment I will add here.

The pushlog url between those two builds is: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0d037f6863771e24c74eca997030f8296af24af8&tochange=6e52d2a6585df26518f5d6e9de03b2486e8f8f4c.

Mozregression will point to:
Backed out 4 changesets (bug 1696041) for causing gecko decision task failure. CLOSED TREE

Backed out changeset a0b814900c36 (bug 1696041)
Backed out changeset d380f63d1926 (bug 1696041)
Backed out changeset 7699e68d6822 (bug 1696041)
Backed out changeset 1c4906861110 (bug 1696041)

Hope this helps!

Flags: needinfo?(catalin.sasca)

Bug 1700873 maybe, from the pushlog in comment 5?

Flags: needinfo?(htwyford)
See Also: → 1724956
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 93.2 - Aug 23 - Sep 5
Points: --- → 1
Flags: needinfo?(htwyford)

This bug happened because we override the existing :root rule with transparent !important. I verified the fix with a Windows 8.1 VM and verified that bug 1700873 does not recur.

Attachment #9239189 - Attachment is obsolete: true

This was fixed in bug 1724956.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Depends on: 1724956
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

The patch landed in nightly and beta is affected.
:harry, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(htwyford)

Bug 1724956 was uplifted so I'm clearing needinfo.

Flags: needinfo?(htwyford)
You need to log in before you can comment on or make changes to this bug.