Closed Bug 1714546 Opened 2 months ago Closed 2 months ago

Captive Portal Detection showing up when no CP

Categories

(Core :: Networking, defect)

Firefox 89
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: iampowerslave, Unassigned)

References

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Opened Firefox

Actual results:

Showed a bar on top saying that I should login to a Captive Portal, clicked and sent me here https://support.mozilla.org/en-US/kb/captive-portal

Expected results:

Nothing
I'm in my home network as usual and it never happened before it updated to 89.0
I do have a proxy and I do have a Firewall and it's config never changed for years. But now FF is giving me this message which I can't dismiss forever.

Thank you for the report.
Could you possibly record some HTTPS logs for us, using these instructions? https://firefox-source-docs.mozilla.org/networking/http/logging.html
Thanks!

Flags: needinfo?(iampowerslave)
Attached file log.txt-main.11412.zip
Flags: needinfo?(iampowerslave)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #2)

Thank you for the report.
Could you possibly record some HTTPS logs for us, using these instructions? https://firefox-source-docs.mozilla.org/networking/http/logging.html
Thanks!

Hi!

I have added log.txt-main.11412.zip to the case.

Are these files enough?

Regards,

David

Thanks for the log. It only shows one of the captive portal attempts, and the channel seems to be OK.
Could you add CaptivePortalService:5 to the list of logged modules and try again?
Thanks!

Flags: needinfo?(iampowerslave)
Attached file log.txt-main.9336.zip

New log with the requested changes

Flags: needinfo?(iampowerslave)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #5)

Thanks for the log. It only shows one of the captive portal attempts, and the channel seems to be OK.
Could you add CaptivePortalService:5 to the list of logged modules and try again?
Thanks!

Hi!

Just uploaded a new log file (log.txt-main.9336.zip) with those changes included

Regards,

David

Unfortunately the log misses most the CP attempts, and only shows the last one which gets aborted.
Could you try with the environment variables?
https://firefox-source-docs.mozilla.org/networking/http/logging.html#windows
Maye sure to add CaptivePortalService:5 to MOZ_LOG=

Thanks!

Flags: needinfo?(iampowerslave)
Flags: needinfo?(iampowerslave)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #8)

Unfortunately the log misses most the CP attempts, and only shows the last one which gets aborted.
Could you try with the environment variables?
https://firefox-source-docs.mozilla.org/networking/http/logging.html#windows
Maye sure to add CaptivePortalService:5 to MOZ_LOG=

Thanks!

Hi. I did that before in about:networking, but now I've tried launching from CMD

See the new attached file log.txt.child-1.moz_log.zip

In bug 1433500 we changed the URL of the captive portal detection.
Before it was loading a TXT file, not it's loading a HTML file, so I assume your proxy might be interfering with it.
Could you tell us:

  1. Does the bug happen without a proxy?
  2. What does your proxy do?
Flags: needinfo?(iampowerslave)
See Also: → 1433500

(In reply to Valentin Gosu [:valentin] (he/him) from comment #8)

Unfortunately the log misses most the CP attempts, and only shows the last one which gets aborted.
Could you try with the environment variables?
https://firefox-source-docs.mozilla.org/networking/http/logging.html#windows
Maye sure to add CaptivePortalService:5 to MOZ_LOG=

Thanks!

Hi. I did that before in about:networking, but now I've tried launching from CMD

See the new attached file log.txt.child-1.moz_log.zip(In reply to Valentin Gosu [:valentin] (he/him) from comment #11)

In bug 1433500 we changed the URL of the captive portal detection.
Before it was loading a TXT file, not it's loading a HTML file, so I assume your proxy might be interfering with it.
Could you tell us:

  1. Does the bug happen without a proxy?
  2. What does your proxy do?

Hi.

  1. The bug does not happen without a proxy
  2. The proxy filters scripts and stuff from websites (http, not https)

Regards,

David

Flags: needinfo?(iampowerslave)

I'm tentatively going to close this bug as invalid.
The response to the CP page is a HTML file containing a meta redirect.
The redirect is only relevant if the page are loaded in a tab. The CP checker only verifies if the response content is the same byte-for-byte.
Technically this should be fixed if we fix bug 1549393.
Given that we haven't received many reports about CPs in 89, I assume this proxy setup is quite rare.
Is the proxy-setup you're using custom made, or is it "a pre-packaged solution"?

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Flags: needinfo?(iampowerslave)
Resolution: --- → INVALID
See Also: → 1549393

(In reply to Valentin Gosu [:valentin] (he/him) from comment #13)

I'm tentatively going to close this bug as invalid.
The response to the CP page is a HTML file containing a meta redirect.
The redirect is only relevant if the page are loaded in a tab. The CP checker only verifies if the response content is the same byte-for-byte.
Technically this should be fixed if we fix bug 1549393.
Given that we haven't received many reports about CPs in 89, I assume this proxy setup is quite rare.
Is the proxy-setup you're using custom made, or is it "a pre-packaged solution"?

It is the "Proxomitron" it has rules so I think you'll consider it custom made.

Flags: needinfo?(iampowerslave)
You need to log in before you can comment on or make changes to this bug.