ability to apply filters at any time on any set of messages

VERIFIED DUPLICATE of bug 11033

Status

MailNews Core
Filters
--
enhancement
VERIFIED DUPLICATE of bug 11033
16 years ago
10 years ago

People

(Reporter: Chris Pickett, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Hi.  I would like to create a new filter, and then apply to filter to as many
messages as I like, be they in my Inbox, my Sent Items, or one of my local
folders, and I would like to be able to select which folders it applies to. 
Furthermore, I don't want to have the filter affect all future incoming messages
... I need it as a way to organize already existing downloaded messages.  Is
this possible?  I know OE supports this kind of thing (or to my recollection),
and it doesn't seem so difficult.  On a similar note, it would be nice to right
click on a message and choose "block sender", and have that create _and_ apply a
filter for that sender that moves messages into the trash, including the one I
just got.  Right now, I find the filter functionality is very limited because it
only applies to future messages.  Please help me ... I believe this is a big
change that would very positively affect usability and likeableness and all that. :)

Cheers,
Chris Pickett

P.S.  I'm submitting this as a new feature request, but if nobody gets back to
me for over a month then I'll file it as a bug because I believe it's that
important.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
P.S.  I'm submitting this as a new feature request, but if nobody gets back to
me for over a month then I'll file it as a bug because I believe it's that
important.

Don't submitt it twice (This doesn't help to fix it and it makes no difference.
You can also loose your bugzilla Account if you start to file the same bug x time) !
This is not a bug, this is an enhancement.
And search before you file a bug and of course only one problem/bug

*** This bug has been marked as a duplicate of 11033 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.