Closed Bug 1714586 Opened 5 months ago Closed 3 months ago

Unable to add calendars if the initial setup is not completed

Categories

(Calendar :: General, defect, P2)

Thunderbird 90

Tracking

(thunderbird_esr78 unaffected, thunderbird90 affected)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird90 --- affected

People

(Reporter: dpa-mozilla, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

I delete ~./cache/thunderbind and ~/.thunderbird. Then I start TB90b1. It offers me to setup an account, I do not setup account. I go in the Calendar tab. On the left there is a + for new calendars, but that + cannot be clicked. The File→New menu shows a “Calendar…” entry, but the entry is disabled.

In the “Home” screen “Choose to Setup” when I click on “Calendar” I cen set up a calendar. I go for ”On the Network” calendar. As location I type cal.aegee.org, without username. I check “This location doesn’t require credentials”. and “Offline support”.

The calendars get discovered, and the events do appear in the calendar. However the “Calendar +” tab on the left does not show any calendars. The “Events in the next 31” days also shows nothing. The Day, Multiweek and Month views cannot be clicked, only the Week view is visible by default.

Expected results:

The discovered calendas shall be displayed on the left panel.

The “Events in the next 31 days” should be displayed.

The < and > buttons (left and right from “Today” shall be clickable, but are not.

The buttons “Day”, “Multiweek” and “Month” on the right shall be clickable.

The + (add new calendars) button after the “Calendar” text should be clickable.

The File → New → Calendar… menu shall be enabled.

What's the "Events in the next 31"? Is that something from an add-on?
I tried your steps to reproduce, and it all seems to work just fine to me (on daily).

I call rm -r ~/.thunderbind ~/.cache/thunderbird. Then I start TB 90.0b1. It offers the “Account setup” tab. I close the tab, without filling it. I switch to the calendar tab. The Plus sign after “Calendar” on the left cannot be clicked. I use Fedora 34.

The “Events in the next 31 days” is a filter in the calendar tab, positioned at the top on the window, before the word “contains”.

The error log contains:

Unknown Collection "thunderbird/hijack-blocklists" RemoteSettingsClient.jsm:160
    UnknownCollectionError resource://services-settings/RemoteSettingsClient.jsm:160
    sync resource://services-settings/RemoteSettingsClient.jsm:470
    InterpretGeneratorResume self-hosted:1482
    AsyncFunctionNext self-hosted:692
    
    
Unknown Collection "thunderbird/url-classifier-skip-urls" RemoteSettingsClient.jsm:160
    UnknownCollectionError resource://services-settings/RemoteSettingsClient.jsm:160
    sync resource://services-settings/RemoteSettingsClient.jsm:470
    InterpretGeneratorResume self-hosted:1482
    AsyncFunctionNext self-hosted:692
    
    
NS_ERROR_FILE_NOT_FOUND: 7 SessionStoreFunctions.jsm:106
    SSF_updateSessionStoreForWindow resource://gre/modules/SessionStoreFunctions.jsm:106
    UpdateSessionStoreForStorage resource://gre/modules/SessionStoreFunctions.jsm:49
    
Uncaught TypeError: this.tree.getRowAt is not a function
    getItemFromEvent chrome://calendar/content/calendar-unifinder.js:618
    onpopupshowing chrome://messenger/content/messenger.xhtml:1

NS_ERROR_FILE_NOT_FOUND: SessionStoreFunctions.jsm:106
    SSF_updateSessionStoreForWindow resource://gre/modules/SessionStoreFunctions.jsm:106
    UpdateSessionStoreForStorage resource://gre/modules/SessionStoreFunctions.jsm:49
    openWindowPrompt resource://gre/modules/Prompter.jsm:1290
    openPrompt resource://gre/modules/Prompter.jsm:1126
    openPromptSync resource://gre/modules/Prompter.jsm:1105
    confirmEx resource://gre/modules/Prompter.jsm:1529
    confirmEx resource://gre/modules/Prompter.jsm:305
    defaultAllowConnection resource://devtools/shared/security/prompt.js:150
    authenticate resource://devtools/shared/security/auth.js:196
    _authenticate resource://devtools/shared/security/socket.js:849
    _handle resource://devtools/shared/security/socket.js:746
    AsyncFunctionNext self-hosted:692

Ah, with a blank profile I see the disabled adding of calendars. I guess finishing the setup is needed to enable it...

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Assignee: nobody → alessandro
Priority: -- → P2
See Also: → 1716876
Summary: Calendars are hard to add and are then hidden → Unable to add calendars if the initial setup si not completed
Status: NEW → ASSIGNED
Attachment #9227557 - Attachment description: Bug 1714586 - Compelte the startup process if the user cancels the account setup without configuring any account. r=mkmelin → Bug 1714586 - Complete the startup process if the user cancels the account setup without configuring any account. r=mkmelin
Regressed by: 1697575
Summary: Unable to add calendars if the initial setup si not completed → Unable to add calendars if the initial setup is not completed
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/bdd6c6bc85ff
Complete the startup process if the user cancels the account setup without configuring any account. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f51d1ec2642e
Backed out changeset bdd6c6bc85ff for test failures. r=backout

comm/mail/test/browser/account/browser_mailAccountSetupWizard.js and lots of others were failing

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Sorry for not launching a try-run right away.
The issue was that I was running the closing tab like a successful account setup, therefore the code was making the Mail Tab forcibly visible even when it shouldn't.
Patch updated and try-run: https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=d51642fdeb2fb8d636c3885994636a13bcdb6432

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/de22929dafc3
Complete the startup process if the user cancels the account setup without configuring any account. r=mkmelin

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED

When you check this in can you please fix the typo in the comment.

Flags: needinfo?(mkmelin+mozilla)

Sure.

Flags: needinfo?(mkmelin+mozilla)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c66dd767f252
Follow up: fix test failures due to undefined gMainWindow. r=darktrojan

Duplicate of this bug: 1718737

Comment on attachment 9227557 [details]
Bug 1714586 - Complete the startup process if the user cancels the account setup without configuring any account. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1697575
User impact if declined: if the user exits the account setup tab before completing, the calendar and other areas are not properly initialized, making them impossible to use.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9227557 - Flags: approval-comm-beta?

Comment on attachment 9228264 [details]
Bug 1714586 - Follow up: fix test failures due to undefined gMainWindow. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): bug 1697575
User impact if declined: nothing for the user, this issue only affects debug tests
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): very low

Attachment #9228264 - Flags: approval-comm-beta?

Comment on attachment 9227557 [details]
Bug 1714586 - Complete the startup process if the user cancels the account setup without configuring any account. r=mkmelin

[Triage Comment]
this will go into 91

Attachment #9227557 - Flags: approval-comm-beta? → approval-comm-beta-

Comment on attachment 9228264 [details]
Bug 1714586 - Follow up: fix test failures due to undefined gMainWindow. r=darktrojan

[Triage Comment]
this will go into 91

Attachment #9228264 - Flags: approval-comm-beta? → approval-comm-beta-

I delete ~/.cache/thunderbird and ~/.thunderbird, then I start TB91b1. I do not create an email account. I open the calendar tab and click on “Add calendars”. As location I type aegee.org, This location does not require credentials, Do offline support. → Find calendars.

Today is 21st July.
In the Calendar tab in the Month and Multiweek view I see two events:

  • New “Birthdays” calendar (in the Miscellaneous calendar) and
  • SUroVision: #OpenSUp (in the Summer Universitis calendar)

In the Day view both events are visible. But the first takes only one line at the top of the view, while the second event occupies the time from 00:00 to 24:00.

In the Week view the “SUroVision: #OpenSUp” event is not displayed.

However, once I click in the upper side of the window (where the “Events in the next 7 Days” are selected) then all events are displayed in the Day view.

I restart Thunderbird. The calendars are not displayed any more (remember: I have not setup a Mail account, this might be relevant), but the events are in the calendar.

Now I cannot switch to the Multiweek or Month view.

I delete ~/.cache/thunderbird and ~/.thunderbird, then I start TB91b2 (the text above is for tb91beta1, now for tb91b2). I do not setup mail account, go to the calendars tab. I cannot add new calendars.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This is by design as we don't run the Calendar init code unless the Account Setup tab is closed.
If you don't close the Account Setup tab, the rest of the application is not initialized.

We need to decide if we want to fully support using TB without any email account (not even going through a first setup to create local folders) and initialize all the other non-mail features at startup.

Let's move this discussion to another bug.

Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED

Actually, we don't need a new bug since what you're expecting from your workflow is in bug 942615.

(In reply to Alessandro Castellani [:aleca] from comment #20)

We need to decide if we want to fully support using TB without any email account (not even going through a first setup to create local folders) and initialize all the other non-mail features at startup.

Up to now, TB always been usable without email account... e.g using it to only manage calendars.

There is no compelling reason to prevent TB feature to be unusable just because an email account is not setup... all feature shall work independently from the other, and well together where applicable... End-userd shall be able to choose how they want to use TB not being imposed to srtup an email account if they just want to use TB to manage contacts, chat, or just as a calendar system...

On a separate note, preventing end-users to setup a calendar because initial setup tab is still opened is wrong by design... and should be considered as a bug and fixed as such... one direct consequences is that it makes TB looks bad and faulty...

You need to log in before you can comment on or make changes to this bug.