Closed Bug 1714639 Opened 1 year ago Closed 11 months ago

Tab modal print shows blank on parent process pages

Categories

(Toolkit :: Printing, defect)

defect

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
firefox91 + verified
firefox92 --- verified

People

(Reporter: mstriemer, Assigned: emilio)

References

Details

Crash Data

Attachments

(1 file)

With the changes for the simplify page mode from bug 1666247, the tab modal print crashes on the about:sessionrestore page. There's a patch there to disable the dialog, but this should be investigated and fixed.

I'd bet this is because about:sessionrestore is a parent process page. Thunderbird is also now crashing when printing from the parent process. Please have a look soon, this is pretty important for us, and our one release for the year is just around the corner.

If this line runs, it crashes. I'll keep digging but you'll have a better idea than I do.

Flags: needinfo?(mstriemer)
See Also: → 1719625

Emilio had a fix for this in bug 1718204 but it hasn't landed yet. Maybe that will help with Thunderbird?

Depends on: 1718204
Flags: needinfo?(mstriemer) → needinfo?(geoff)

(In reply to Mark Striemer [:mstriemer] from comment #2)

Emilio had a fix for this in bug 1718204 but it hasn't landed yet. Maybe that will help with Thunderbird?

With this fix TB does no more crash. The print dialog appears but the "Preparing preview" isn't shown and the preview is empty.

Emilio, any idea why the preview might not be loading with the fix from bug 1718204?

Flags: needinfo?(emilio)

I agree with Richard's assessment. The browser's there and visible (you can set the CSS background colour and that shows), but it's empty.

Flags: needinfo?(geoff)

On 92.0a1 (2021-07-13) (64-bit)
I agree with Comment 5:
a) if I rt-mouse on any email in the message list I get the PrinPreview pages, printer details are complete but the print preview frame is empty
b) open same email and file -> print makes TB crash.
Re Wayne's question in Thunderbird bug 1720397, seems to be same result on any mail I tried.

Blocks: 1720397
Duplicate of this bug: 1720454
Crash Signature: [@ nsGlobalWindowOuter::Print]
See Also: → 1663859
Assignee: nobody → emilio

We need to be displayed when cloning into a same-process frame, so that
the preview code hooks up to the view tree correctly and the frame is
correctly painted.

This works for out-of-process frames, but mostly by chance.

Fortify the printPreview() API code to gracefully handle that case, and
remove the sessionrestore special-case which is not really special.

Flags: needinfo?(emilio)
Blocks: 1720713

(in case it's not obvious) very much need an uplift to 91 beta

[Tracking Requested - why for this release]: Printing parent process pages crashes.

Summary: Tab modal print crashes Firefox on about:sessionrestore → Tab modal print shows blank on parent process pages

Thanks for setting tracking.

I don't know about Firefox, but this is a blocker for releasing TB91. (I hesitate to use that severity)

Severity: -- → S2
See Also: → 1721671
See Also: 1721671
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f032f4d08cfd
Don't call FrameLoader.printPreview in hidden frames. r=mstriemer,jwatt
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch

Comment on attachment 9231361 [details]
Bug 1714639 - Don't call FrameLoader.printPreview in hidden frames. r=mstriemer,jfkthame

Beta/Release Uplift Approval Request

  • User impact if declined: Parent process pages show blank until print settings are changed at least once.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): relatively simple fix
  • String changes made/needed: none
Attachment #9231361 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9231361 [details]
Bug 1714639 - Don't call FrameLoader.printPreview in hidden frames. r=mstriemer,jfkthame

Approved for 91 beta 7 beta 8, thanks.

Attachment #9231361 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Duplicate of this bug: 1720397
Duplicate of this bug: 1721817

Reproduced both problems (the initial one with Fx 91.0b4, and the current one after a fix for 1718204 landed with Fx 91.0b5) on Windows 10. .
Verified fixed with Fx 92.0a1 (2021-07-26) and Fx 91.0b8 (treeherder build) on Windows 10, macOS 11.0, Ubuntu 18.04

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.