Flag UI is confusing

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Attachments & Requests
P3
normal
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: Joel Peshkin, Assigned: Max Kanat-Alexander)

Tracking

2.17
Bugzilla 2.18

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In the UI for setting up flags (editflagtypes.cgi), it is not clear that the
default if nothing is either specificically included or excluded is that
everything is excluded.  Since the drop-down fields look very inclusive by
default, this should either be explicitly stated in the text of the UI or else
the default when a new flag is created should be to make it included in all.

Also, the whole flags feature needs a serious doc update or a good explanation
in the UI.
Blocks: 171553
Created attachment 104755 [details] [diff] [review]
patch v1: defaults to all categories for new flag type

I think defaulting to all categories for a new flag type is reasonable.  Here's
a patch that does that.
(Reporter)

Comment 2

15 years ago
Comment on attachment 104755 [details] [diff] [review]
patch v1: defaults to all categories for new flag type

r=joel

Flags still needs a doc update
Attachment #104755 - Flags: review+
(Reporter)

Updated

15 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
Checking in editflagtypes.cgi;
/cvsroot/mozilla/webtools/bugzilla/editflagtypes.cgi,v  <--  editflagtypes.cgi
new revision: 1.2; previous revision: 1.1
done

Reassigning to barnboy for the docs work.
Assignee: myk → matthew
Status: ASSIGNED → NEW

Updated

15 years ago
Status: NEW → ASSIGNED
This should go to the Documentation component and have its dependency dropped,
since it's "fixed" in terms of code.
No longer blocks: 171553
Component: Attachments & Requests → Documentation
Matthew is still going to be around to help out, but Jake is taking over the
day-to-day front-line triage type stuff for Documentation
Assignee: matthew → jake
Status: ASSIGNED → NEW
*** Bug 191163 has been marked as a duplicate of this bug. ***
Jake is leaving for a while (Reserve unit got called up), and we don't have a
new docs owner yet.  Anyone interested in helping out, please add
documentation@bugzilla.org to your watch list in your email preferences in Bugzilla.
Assignee: jake → documentation
(Assignee)

Comment 8

14 years ago
Um, as far as I can see, there isn't any flags documentation at all, now... I'll
write it, but I wanted to know if there's something I should be modifying, or if
I should just create it out of whole cloth.
Assignee: documentation → mkanat

Comment 9

14 years ago
> Um, as far as I can see, there isn't any flags documentation at all, now...

Yeah. Those are bugs 198019 and 198020.

Comment 10

14 years ago
per comment 9, this should be resolved as fixed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Documentation → Attachments & Requests
Resolution: --- → FIXED
Nothing in comment 9 says this is fixed...  those bugs are about documentation,
not better UI.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
OK, you're right.  I should read the whole bug. :)  Comment 4 is where it says
so though. :)
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.