jpg sent via "content-disposition: attachment; filename=image.jpg" has image.jpg.php as filename

VERIFIED DUPLICATE of bug 65827

Status

VERIFIED DUPLICATE of bug 65827
16 years ago
2 years ago

People

(Reporter: asmith, Assigned: law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

using the following header sent from a download.php script:

<?php
Header("Content-Type: application/octet-stream");
Header("Content-Length: ".filesize(/webserver/protected_dir/image.jpg));
Header("Content-Disposition: attachment; filename=image.jpg");
readfile(/webserver/protected_dir/image.jpg);
?>

Mozilla is using the filename of image.jpg.php instead of image.jpg when it is
prompting to save to disk. This seems to only happen for my site visitors who
have just installed mozilla 1.1. As a workaround, I had them add
application/octet-stream as a file type under helper applications. 

shouldn't mozilla be honoring the filename=image.jpg part when
content-disposition is attachment?

Reproducible: Always

Steps to Reproduce:
1. Install moz1.1 on a fresh system.
2. Helper applications list will be empty.
3. click on download.php that uses "content-type: application/octet-stream" and
"content-disposition: attachment; filename=image.jpg"

Actual Results:  
Mozilla prompts to either open by choosing an application or save to disk, with
the filename being used as image.jpg.php

Expected Results:  
Mozilla should honor the filename=image.jpg part of the content-disposition, and
start with image.jpg as the suggested filename.
This is a duplicate.  Please find the original and mark it so...

(and yes, this bug sucks).
Whiteboard: DUPEME
(Reporter)

Comment 2

16 years ago
Sorry for not doing search first.

It's a bit confusing looking through all the results from a search on
'disposition' but from i've read, bug 65827 seems to be the one. Marking as a dupe.



*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.