Closed Bug 1715128 Opened 1 year ago Closed 10 months ago

Port bug 1698814: Clean up --lwt-toolbar-field-* variables after proton

Categories

(Thunderbird :: Upstream Synchronization, task)

Tracking

(thunderbird91 unaffected)

RESOLVED FIXED
92 Branch
Tracking Status
thunderbird91 --- unaffected

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file, 4 obsolete files)

No description provided.

Bug 1698814 is not yet fully reviewed but we don't know how fast M-C is until their bug lands. I tested it with the M-C patches.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9225728 - Flags: review?(alessandro)

Updated patch to better work with different combinations of system theme and TB theme.

The download tab has some issues which I address in a new bug.

Attachment #9225728 - Attachment is obsolete: true
Attachment #9225728 - Flags: review?(alessandro)
Attachment #9225946 - Flags: review?(alessandro)

Updated patch to apply. No need to review now as the M-C bug has no review yet.

Attachment #9225946 - Attachment is obsolete: true
Attachment #9225946 - Flags: review?(alessandro)
Attached file zielgerade (obsolete) —
Attachment #9234716 - Attachment is obsolete: true

Bug 1698814 is now on the home straight to land. We need to land it together when it merges to M-C because it changes a lot of variable names which will break the styling. If all goes well it will be probably in the next Daily.

Attachment #9227938 - Attachment is obsolete: true
Attachment #9234717 - Flags: review?(mkmelin+mozilla)

Bug 1698814 landed.

Comment on attachment 9234717 [details] [diff] [review]
1715128-clean-up-lwt-toolbar-field-variables.patch

Review of attachment 9234717 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Richard! r=mkmelin
Attachment #9234717 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → 92 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/cd6a7b3ab3a4
Port bug 1698814: Clean up --lwt-toolbar-field-* variables after proton. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Regressions: 1724633
Blocks: 1726171
You need to log in before you can comment on or make changes to this bug.