Hebrew Geresh and GERSHAYIM are incorrectly displayed as ?

VERIFIED FIXED

Status

()

Core
Internationalization
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Shoshannah Forbes, Assigned: smontagu)

Tracking

({intl})

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20020922
Build Identifier: 2002091010 (1.2a)

the page 
http://people.netscape.com/smontagu/writings/HebrewNumbers.html
uses the character geresh and gershayim- mozilla on os9 displays them
incorrectly as qustion mark (this display ok under osx except for the fact that
they are aligned a bit to high, althugh mozilla is using a diffrent font than
sepcified in the page)

Reproducible: Always

Steps to Reproduce:
1. go to http://people.netscape.com/smontagu/writings/HebrewNumbers.html
2. scroll down to the geresh and gershayim
3. see display

Actual Results:  
you get question marks

Expected Results:  
either proper characters, or replacement ones if mozilla is unable to display
the correct ones.
(Reporter)

Comment 1

15 years ago
Created attachment 101053 [details]
screen shot of the page
(Reporter)

Comment 2

15 years ago
Created attachment 101055 [details]
the same page under osx

Comment 3

15 years ago
wfm using build 20020927 on Linux, could be MacOS9 specific bug.

Comment 4

15 years ago
Shoshannah, does any OS 9 font installed with the Hebrew Language Kit contains glyphs at 
U05F3 and U05F4?

Reassigning to Internationalization.
Assignee: mkaply → yokoyama
Component: BiDi Hebrew & Arabic → Internationalization
Keywords: intl
QA Contact: zach → ruixu
(Reporter)

Comment 5

15 years ago
how do I check?
(Assignee)

Comment 6

15 years ago
Created attachment 101146 [details]
Test case with some other punctuation marks

What about other Hebrew punctuation? This test case includes five punctuation
characters which are defined in Unicode and the windows-1255 encoding, but not
in iso-8859-8 or MacHebrew. I would expect similar problems with all of them.
(Assignee)

Comment 7

15 years ago
If we add these characters to intl/unicharutil/tools/gentransliterate.pl will
the Mac pick them up from there? They all have reasonable ASCII fallbacks.
(Assignee)

Comment 8

15 years ago
Taking myself
Assignee: yokoyama → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

15 years ago
Created attachment 101162 [details] [diff] [review]
Patch

If the answer to the question in comment 7 is yes, then this patch will fix the
bug.

Updated

15 years ago
QA Contact: ruixu → ylong
(Reporter)

Comment 10

15 years ago
indeed the test case displayes with question marks. see screen shot
(Reporter)

Comment 11

15 years ago
Created attachment 101241 [details]
screen shot of test case in os9 with mozilla 1.2a
(Reporter)

Comment 12

15 years ago
Comment on attachment 101241 [details]
screen shot of test case in os9 with mozilla 1.2a

><HTML><BODY><P><IMG src="http://bugzilla.mozilla.org/attachment.cgi?id=101241&amp;action=view" alt="The image “http://bugzilla.mozilla.org/attachment.cgi?id=101241&amp;action=view” cannot be displayed, because it contains errors."/></P></BODY></HTML>
Attachment #101241 - Attachment is obsolete: true
(Reporter)

Comment 13

15 years ago
Created attachment 101242 [details]
proper screen shot this time...

Comment 14

15 years ago
Comment on attachment 101162 [details] [diff] [review]
Patch

r=ftang looks good
Attachment #101162 - Flags: review+

Comment 15

15 years ago
Comment on attachment 101162 [details] [diff] [review]
Patch

sr=rbs
Attachment #101162 - Flags: superreview+
(Assignee)

Comment 16

15 years ago
Fix checked in. ftang and I tested it together on a Mac yesterday, and the
fallbacks all work in attachment 101146 [details]. HYPHEN-MINUS for HEBREW MAKAF is not
ideal because its vertical position is much lower than the normal makaf, but
it's certainly better than a question mark.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 17

15 years ago
Verified fixed on 10-11 trunk build / Mac9.1-JA.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.