Buttton layout changes when focus is lost or gained

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: mats, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
TO REPEAT:
1. start mozilla
2. select menu-item "Debug" -> "Viewer Demos" -> "#8 Form"
3. press (but don't release) "This button contains a table"
4. still pressed - move mouse outside of the button
5. hit "TAB" key
(6. move the mouse pointer inside the button resets the layout)
(7. Hit Shift+TAB, bug appears again)

ACTUAL:
At step 5, the button changes size and the table inside is laid out differently

EXPECTED:
No layout/size changes when focus is lost or gained

VERSION & OS:
Mozilla nightly build 1999-10-22-09-M11 on Windows 98 SE.

Updated

18 years ago
Assignee: karnaze → kmcclusk

Comment 1

18 years ago
Reassigning to Kevin.

Updated

18 years ago
Assignee: kmcclusk → rods
Reassigning to Rod

Updated

18 years ago
Assignee: rods → evaughan

Comment 3

18 years ago
Eric, I will let you fix this.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

18 years ago
This is a bogus style rule. The problem is the focus border is removed and the
space for it is removed. Focus should have a transparent focus border when its
not in focus. I'll fix it.

Comment 5

18 years ago
QA Contact update.

Updated

18 years ago
Target Milestone: M15

Comment 6

18 years ago
targetting p3 for m15

Comment 7

18 years ago
Not seeing this on any platform.  Marking WORKSFORME on:
- Win98 2000-01-25-20 Commercial build
- Linux6 2000-01-25-20 Commercial build
- MacOS86 2000-01-26-03 Commercial build
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
Marking VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.