Closed Bug 171571 Opened 17 years ago Closed 17 years ago

font css rule randomly dissing 1px horizontal borders

Categories

(Core Graveyard :: GFX, defect, P3)

x86
All
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 176237
Future

People

(Reporter: mozbugs, Assigned: kmcclusk)

References

()

Details

Attachments

(3 files)

screen shot: http://tippetevling.net/ala/realworld.png

reduced test case: http://mason.gmu.edu/~danders2/missingBordersALAReduced.html

see it working (font css removed):
http://mason.gmu.edu/~danders2/missingBordersNotMissingWithoutFontCss.html

related case: http://mason.gmu.edu/~danders2/ngcpMissingBorder.html
(look near Guidance tab, 2nd box on right)

Selective borders are missing when a font rule is specified.

On the A List Apart example, the font .../1.5... (in body rule) is the culprit
On the related case, simply deleting the 
font-size: 10px;
from the body rules will allow the border to be shown.

This bug either only applies to Windows 
('cuz at least the ALA page looks fine on GNU/Linux) 
or it has something to do with a particular group of fonts
('cuz I'm just starting to use GNU/Linux and have about 2 fonts to choose from)
Probably a windows only bug
Nope. I've had this problem before on Mac OS X, and my solution was to set the
border to 2px. It is a roundoff error where totals and averages and whatever in
some circumstances will make thin lines vanish or become 1px thinner.
confirmed with linux trunk build 20020928 with
http://mason.gmu.edu/~danders2/missingBordersALAReduced.html
after putting another window over it and then removing the window, Mozilla will
sometimes draw it properly.

==> GFX Compositor
Assignee: attinasi → kmcclusk
Status: UNCONFIRMED → NEW
Component: Layout → GFX Compositor
Ever confirmed: true
OS: Windows 2000 → All
My friends website uses css and I have noticed an oddity.

The site is http://www.toomuchsexy.org/ (it is not porn, it's a blog) and on the
right side I have this set as part of the css code:
> .sidetitle {
> font-family:verdana, arial, sans-serif;
> color:#CCCCCC;
> font-size:9px;
> font-weight:bold;
> background:#333333;
> line-height:140%;
> padding:2px;
> margin-top:10px;
> border-bottom:1px solid #666666;
> text-transform:uppercase;
> letter-spacing: .2em;
> }

The weird thing is, border-bottom:1px solid #666666; does not always work. As
you can see:
Archives is underlined, Categories isn't. Recent Entries is underlined, the Poll
isn't.

Just to confirm the last three reports.
This is the Mac OS X screenshot for ToomuchSexy.
Changing summary from 
font css rule randomly dissing 1px horizontal (top?) borders
to
font css rule randomly dissing 1px horizontal borders
'cuz on the alistapart examples, they are bottom borders.
Summary: font css rule randomly dissing 1px horizontal (top?) borders → font css rule randomly dissing 1px horizontal borders
Priority: -- → P3
Target Milestone: --- → Future
Attached file Simple test case HTML
The bottom border of Box 2 is consistently missing
on Build ID 2002110408 on Windows 2000.

This test case is minimal in that the missing border reappears when any of the
other CSS lines are removed.
Shows faulty rendering of previous attachment in build 2002110408.

To clarify, it is the bottom border of the second <div class="test1"> that is
missing.
Marking duplicate of later bug that more of the relevant people know about.

*** This bug has been marked as a duplicate of 176237 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.