Closed Bug 1715890 Opened 3 years ago Closed 3 years ago

Ensure browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js works with SHIP+BFCache

Categories

(WebExtensions :: General, task, P3)

task

Tracking

(Fission Milestone:M7a)

RESOLVED WORKSFORME
Fission Milestone M7a

People

(Reporter: smaug, Unassigned)

References

(Blocks 1 open bug)

Details

See bug 1715550
The test has failed every now and then in the past even without Fission

FWIW, the failure looks similar to
bug 1591690

Severity: -- → N/A
Priority: -- → P3

Tom, can you please look into why this test is failing with bfcacheInParent enabled?
I checked previous failures of this, and they seem to be different failures, so this one needs some investigation.

Also, what would be the impact of such failure? Which one does this block?

  1. Enabling bfcache in nightly
  2. Enabling bfcache in beta
  3. Release exp so M8
Fission Milestone: --- → ?
Flags: needinfo?(tomica)

Half the failures seem to be on Windows, but I can't seem to reproduce locally. Also strange that none of the failures are on linux.

Olli, any idea why that would be? It's not clear to me, does it fail intermittently or perma? Can you reproduce locally?

mach mochitest --enable-fission --setpref fission.bfcacheInParent=true browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js

Also, what would be the impact of such failure? Which one does this block?

If it's a perma failure, it indicates the extensions API related to sessions is likely broken, which could be related BFcache changes. I would say that blocks enabling in Nightly.

If it's an intermittent and only on certain platforms, it's more likely a test (timing) issue, and would probably only block beta/M8, depending on frequency.

Flags: needinfo?(tomica) → needinfo?(bugs)

The test failed couple of times on Mac and Windows.

I just tried this locally with --verify, and couldn't reproduce on opt nor on debug build.

I triggered browser/components/extensions/test/browser/*
couple of more times on a recent try run
https://treeherder.mozilla.org/jobs?repo=try&selectedTaskRun=GezzE0IUSkOdfuxAmjEJRQ.0&revision=e7cccf596c547737f7c5cf8aba2b58b153eb4b71&test_paths=browser%2Fcomponents%2Fextensions%2Ftest%2Fbrowser%2F

Does the relevant code in extension API rely somehow on sessionstore? There have been some fixes to SessionStore after regressions from last week. Also, there was a SHIP regression which should be now fixed too (though that one should affect to back/forward only).

Flags: needinfo?(bugs)

That try isn't lucky to reproduce this, at least not so far.

Fission Milestone: ? → M7a

This is not seen as failing in latest try run https://treeherder.mozilla.org/jobs?repo=try&revision=76f19083ee9a7d7d7f38f568e2292c5ef30b74f1 . Peter is enabling bfcache in parent today (Bug 1715300). We'll confirm and close tomorrow if this doesn't fail anymore.

There are other common browser/components/extensions/test/browser/browser_ext* intermittents (for example bug 1682361), but this one hasn't showed up on autoland fission runs after bfcache was enabled.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.